Skip to content

Commit

Permalink
app-misc/inputlircd: revbump, fix build with headers-4.4
Browse files Browse the repository at this point in the history
Introduces conditional patch for building against linux-headers-4.4, fixing a
runtime issue with using unknown commands for the lirc socket. Patch and
initial ebuild submitted by user Michael Cook, ebuild updated to EAPI6.

Gentoo-bug: 581410
Package-Manager: portage-2.2.28
  • Loading branch information
wraeth committed Apr 30, 2016
1 parent 623800f commit dfddec8
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
13 changes: 13 additions & 0 deletions app-misc/inputlircd/files/inputlircd-linux-4.4-fix.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
diff --git a/Makefile b/Makefile
index 71bc693..3904632 100644
--- a/Makefile
+++ b/Makefile
@@ -27,7 +27,7 @@ MANDIR ?= $(SHAREDIR)/man

all: $(SBIN)

-names.h: /usr/include/linux/input.h gennames
+names.h: /usr/include/linux/input-event-codes.h gennames
./gennames $< > $@

inputlircd: inputlircd.c /usr/include/linux/input.h names.h
37 changes: 37 additions & 0 deletions app-misc/inputlircd/inputlircd-0.0.1_pre15-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit toolchain-funcs eutils versionator

DESCRIPTION="Inputlirc daemon to utilize /dev/input/event*"
HOMEPAGE="http://svn.sliepen.eu.org/inputlirc/trunk"
SRC_URI="http://gentooexperimental.org/~genstef/dist/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"

src_prepare() {
local ver="$(best_version sys-kernel/linux-headers)"
ver=${ver#sys-kernel/linux-headers-}
if version_is_at_least 4.4 ${ver} ; then
epatch "${FILESDIR}/inputlircd-linux-4.4-fix.patch"
fi

sed -e 's:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' -i Makefile || die

default
}

src_compile() {
emake CC="$(tc-getCC)"
}

src_install() {
emake DESTDIR="${D}" PREFIX=/usr install

newinitd "${FILESDIR}"/inputlircd.init.2 inputlircd
newconfd "${FILESDIR}"/inputlircd.conf inputlircd
}

0 comments on commit dfddec8

Please sign in to comment.