Skip to content

Commit

Permalink
dev-lang/ekopath: Snapshot bump
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Mar 12, 2016
1 parent 95fe178 commit e0296e0
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/ekopath/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST ekopath-2015-12-13-installer.run 57231316 SHA256 85a3fc7df59373bfef32bf9388
DIST ekopath-2015-12-31-installer.run 57236877 SHA256 f8e5a2910ac001ace7d42254553e27f79b62eb6650d89778eced3ff483854917 SHA512 d191ce829c1c285c848c58f7bca194df72975d0d0685cf70c324831ca9ce67729dbf9fa46f36b4e17cc726fb8144739608fa825d4e2dd447b40dc0b1461f9f9b WHIRLPOOL 7988f8c93522aa38ec18c69979789fda1f64ab647d712da02260961a98e7ee75d90525c76947e6f32c073f289af419154d58072e5edac5093fdeaee7489c096c
DIST ekopath-2016-01-24-installer.run 57266129 SHA256 3ea7471dc29ccfd89b7a7cee788243cd94f0b86cbe4345f7576a4444119b1122 SHA512 514e1a317822ca8edf2bfe2f2d99928717876731fbb3949165ded97fe7ed99acf01eb27f862ba9c84e8a3fd4f0c46aa31734925847351ad0b74a4d0bde8c4240 WHIRLPOOL a9ca485f5196563fd5fe449c3ab745c162492eff6c51b560234338ab0aa96b3128fd44e401eb28e50c47425315447c1b8f2f9a80bb9ce59fdac21232c6262f8d
DIST ekopath-2016-03-03-installer.run 57856781 SHA256 0db16cf44f38e170e80230e08cccd2596187c869a3cd9ec74a6c368f9f1cb617 SHA512 c7ddb516f420a2efd278472f2694cad87b6e8e956f56b48473f432cc9b3565e568713915137b980cd03e89003e80a098a29cb7f3fea93f02c590577ef521f0ba WHIRLPOOL a270e5eb8731fc5a8c536d2328b5c5d1012397df895d01009dc2d3751c0f344697069e998d51fcbc183cec719652cbfee0032b3b7ae408f5d9104376f22ddbaa
DIST ekopath-2016-03-11-installer.run 57858541 SHA256 ff4dc9eca6c877a5a28e4249b783b742f2038d9e01fd1ad795bcbd5ad0059fa2 SHA512 339dd9cd2048629c4f1ef95e062b7029094b563cba9d078bebbd2b0d584da4840e3d824203767ee820da5dbd64b31dc1297529fe59ecdd028b1bad2dd602b3ed WHIRLPOOL ea7492fac3fffd611633d8b975fe73e2dcc3869d575de2fc5f9fc0e1694400e393f04728a63f372d2fd3f18a80ccb8d23ef518627e7d9474f4859b7d181af5ea
74 changes: 74 additions & 0 deletions dev-lang/ekopath/ekopath-6.0.713_p20160311.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit versionator multilib pax-utils

MY_PV=$(get_version_component_range 1-3)
DATE=$(get_version_component_range 4)
DATE=${DATE#p}
DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
INSTALLER=${PN}-${DATE}-installer.run

DESCRIPTION="PathScale EKOPath Compiler Suite"
HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"

LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

DEPEND="!!app-arch/rpm"
RDEPEND=""

RESTRICT="bindist mirror"

QA_PREBUILT="
opt/${PN}/lib/${MY_PV}/x8664/*
opt/${PN}/bin/*"

S="${WORKDIR}"

src_unpack() {
cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
chmod +x "${S}/${INSTALLER}" || die
}

src_prepare() {
cat > 99${PN} <<-EOF || die
PATH=${EROOT%/}/opt/${PN}/bin
ROOTPATH=${EROOT%/}/opt/${PN}/bin
LDPATH=${EROOT%/}/opt/${PN}/lib:${EROOT%/}/opt/${PN}/lib/${MY_PV}/x8664/64
MANPATH=${EROOT%/}/opt/${PN}/docs/man
EOF
}

src_install() {
# EI_PAX marking is obsolete and PT_PAX breaks the binary.
# We must use XT_PAX to run the installer.
if [[ ${PAX_MARKINGS} == "XT" ]]; then
pax-mark m "${INSTALLER}"
fi

./"${INSTALLER}" \
--prefix "${ED%/}/opt/${PN}" \
--mode unattended || die

if [[ ! -d ${ED%/}/opt/${PN}/lib/${MY_PV} ]]; then
local guess
cd "${ED%/}/opt/${PN}/lib" && guess=( * )

if [[ ${guess[@]} ]]; then
die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
else
die "No libdir installed"
fi
fi
[[ -x ${ED%}/opt/${PN}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"

rm -r "${ED}/opt/${PN}"/uninstall* || die
doenvd 99${PN}
}

0 comments on commit e0296e0

Please sign in to comment.