Skip to content

Commit

Permalink
media-libs/alsa-lib: Bump to version 1.1.8
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.54, Repoman-2.3.12
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Jan 8, 2019
1 parent 2d83227 commit e063b4c
Show file tree
Hide file tree
Showing 2 changed files with 84 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/alsa-lib/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST alsa-lib-1.1.2.tar.bz2 947423 BLAKE2B 09cd6a625d8f681c5515fd925191fb5468158ed77cc3878c076f4344e4d8f7b15e9872d3d6635710049ca14199851f2343246e94810fe2a0bb0d1e02915c941e SHA512 a6c6675b1fd86955ef5072b9e6090795fc6b0b16f32481bece049e5f100e689be48b6416ff7cf36abfc67e0b94f420e08c15ff13a9701987d6bb69a8fa567e8a
DIST alsa-lib-1.1.6.tar.bz2 989316 BLAKE2B 2aec62d262148571cc1b93ac8053002b61266951caf8b2855fc65b699ec928672748a21ba11a25e14e752a4a85f68b2f77b5ad6af9b2f1fc5e9de41313ace54a SHA512 00117769a3d5c609019b975188d6e7a07d035bd0461f54c5f291e14667620506f1adb6d61350f78d54648850f31965aae3ab0e697bf9e09c988e2d15bf6b09f0
DIST alsa-lib-1.1.7.tar.bz2 1005257 BLAKE2B 0ee0eb9db057421d75436bbed49e0a0ef560700d480a5dc73bc0e9e6abaa29892dc4e4482c671996fbc9f6bb5f70ba645010bd714f30959fef897e3dc906980f SHA512 7cc81464d876a137e9ac9700420bfff7cd528338bdc6e0bdbe313d45c5b97c81f1a9483df0556fe390d54a9db747fbec62e843b42d2cbc740d5a91b015714f6c
DIST alsa-lib-1.1.8.tar.bz2 1002562 BLAKE2B a531ab501943924d007f7ae0e4489deea805ccbc8f2f02d3ee392aa2dbe54ffe31f58ee1744308f851a68f693c83125088708e901d0d83e4a7a5f644ef448aa3 SHA512 50ae107c6efe8200b4c41e0463e099d16e149332f1d3a22c3e81d3e7d980b7f93f3610fc9711ef62067caeb1054e7ea612ba3903bf8a91ebeffa48687cf80eed
83 changes: 83 additions & 0 deletions media-libs/alsa-lib/alsa-lib-1.1.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,83 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )

inherit autotools multilib multilib-minimal python-single-r1

DESCRIPTION="Advanced Linux Sound Architecture Library"
HOMEPAGE="https://alsa-project.org/"
SRC_URI="mirror://alsaproject/lib/${P}.tar.bz2"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="alisp debug doc elibc_uclibc python +thread-safety"

RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
doc? ( >=app-doc/doxygen-1.2.6 )"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

PATCHES=(
"${FILESDIR}/${PN}-1.1.6-missing_files.patch" #652422
)

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
# https://bugs.gentoo.org/509886
use elibc_uclibc && { sed -i -e 's:oldapi queue_timer:queue_timer:' test/Makefile.am || die; }
# https://bugs.gentoo.org/545950
sed -i -e '5s:^$:\nAM_CPPFLAGS = -I$(top_srcdir)/include:' test/lsb/Makefile.am || die
default
eautoreconf
}

multilib_src_configure() {
local myeconfargs=(
--disable-maintainer-mode
--disable-resmgr
--enable-aload
--enable-rawmidi
--enable-seq
--enable-shared
# enable Python only on final ABI
$(multilib_native_use_enable python)
$(use_enable alisp)
$(use_enable thread-safety)
$(use_with debug)
$(usex elibc_uclibc --without-versioned '')
)

ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}

multilib_src_compile() {
emake

if multilib_is_native_abi && use doc; then
emake doc
grep -FZrl "${S}" doc/doxygen/html | \
xargs -0 sed -i -e "s:${S}::"
fi
}

multilib_src_install() {
emake DESTDIR="${D}" install
if multilib_is_native_abi && use doc; then
docinto html
dodoc -r doc/doxygen/html/.
fi
}

multilib_src_install_all() {
find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
dodoc ChangeLog doc/asoundrc.txt NOTES TODO
}

0 comments on commit e063b4c

Please sign in to comment.