Skip to content

Commit

Permalink
net-wireless/gr-doa: initial ebuild, this could be fun
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.16, Repoman-2.3.6
  • Loading branch information
ZeroChaos- committed Dec 15, 2017
1 parent 72c0b85 commit e0720a3
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
42 changes: 42 additions & 0 deletions net-wireless/gr-doa/gr-doa-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )

inherit cmake-utils git-r3 python-single-r1

DESCRIPTION="Gnuradio flowgraphs and modules for Direction of Arrival analysis"
HOMEPAGE="https://github.com/samwhiting/gnuradio-doa"
EGIT_REPO_URI="https://github.com/samwhiting/gnuradio-doa.git"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
IUSE="doc"
#Tests fail, https://github.com/samwhiting/gnuradio-doa/issues/3
RESTRICT="test"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="
>=net-wireless/gnuradio-3.7.0:=[${PYTHON_USEDEP}]
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
virtual/pkgconfig"

S="${WORKDIR}/${P}/gr-doa"

src_configure() {
mycmakeargs=(
-DPYTHON_EXECUTABLE="${PYTHON}"
)
cmake-utils_src_configure
}
src_install() {
cmake-utils_src_install
insinto /usr/share/${PN}
doins -r "${WORKDIR}/${P}/flowgraphs"
}
14 changes: 14 additions & 0 deletions net-wireless/gr-doa/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Rick Farina</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Radio</name>
</maintainer>
<use>
</use>
</pkgmetadata>

0 comments on commit e0720a3

Please sign in to comment.