forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-video/dvdstyler: bump to 2.9.4
Package-Manager: portage-2.2.22
- Loading branch information
Showing
2 changed files
with
69 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST DVDStyler-2.7.2.tar.bz2 5982155 SHA256 b30df3870b9cfcac5bc4387d276aec10e0913ce66c63007f1393123afda180be SHA512 f4913ff5ed11e7cedccb8408bea9adbfae7494afde9062c4acc7e65014af821d4b5acacbce57fd07225cf3af8c21ba552897b50be67f21e242fb6f4baeed000d WHIRLPOOL 070254838db445175401c6d2fb05dc6ee5d79620a598f5a5f0c6d4d8bf9cb5b3ecfc1ad0e708b6289b37b0a5cd0a5c2b0c089c87951b60fe0d48eab85cc9410f | ||
DIST DVDStyler-2.9.2.tar.bz2 7861116 SHA256 88abd17b0dcdfccbdfffe6e80bcfa59df023f1ff2eed782e58d1f793a81dbd1f SHA512 5688f383b03cb0ec6c57659494d1f4f98f72c21e3e125e16ec3adfeac20555d6f26a12d3629417b46f833933f504e1d55a7fcdb2c0926643e0bfadcab8c998be WHIRLPOOL cd857c39a5de581b201b2d78d7a676b05f5dbdef3592fe835158cceb05d8b8e37cf5a4f88514469bbfac908f827843718b733566cac6fd86f6c7700bc49e0431 | ||
DIST DVDStyler-2.9.3.tar.bz2 7861272 SHA256 ffbc22454e210ba8fcad9a7954b426d9dc5ff933527a6e39391d310101128c39 SHA512 c39a1c08ea5e86e05c25443685524c61c26a5fe11e66240884db6b54c117f1cc446634145bc99673eb7de2ed44e3d03277686470dfde3ab78a5943b2667e7b73 WHIRLPOOL d08202272c5ec9fbaec7b049e854cdb413a929b59ee047a99a4d70699f80a2a0a47786335a9bc05d8d7ca905f9137d4f81bc31fd56a78943c71b169999cc0cd3 | ||
DIST DVDStyler-2.9.4.tar.bz2 7863263 SHA256 8b15ec98e3e5ec8c5a1f23eee316f646476e76b86b80d44b7c842887946a39e0 SHA512 8ef8e0241f31957b6c1695876a2067510750b3e997d57c688ceed640110488c2989af12d23147a5b439625cafc5bf7f2d3a8cdda8304b96555f48b6f5553cde4 WHIRLPOOL 07f3a96f83e0d7bbaea4cf01f9c440d63590f632de3ebbb516d7551ced21c9597790149f252f517f627c5d8800e5a1d8737ad15a015eb1f76e7fef4d7dc15dbf |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,68 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
MY_P=${P/dvds/DVDS} | ||
WX_GTK_VER=2.8 | ||
|
||
inherit wxwidgets eutils | ||
|
||
DESCRIPTION="A cross-platform free DVD authoring application" | ||
HOMEPAGE="http://www.dvdstyler.org/" | ||
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="debug +udev" | ||
|
||
COMMON_DEPEND=">=app-cdr/dvd+rw-tools-7.1 | ||
media-libs/libexif:= | ||
>=media-libs/wxsvg-1.3:= | ||
>=media-video/dvdauthor-0.7.1 | ||
>=media-video/xine-ui-0.99.7 | ||
virtual/cdrtools | ||
>=virtual/ffmpeg-9-r1[encode] | ||
virtual/jpeg:0 | ||
>=x11-libs/wxGTK-2.8.7:2.8=[gstreamer,X] | ||
sys-apps/dbus | ||
udev? ( >=virtual/libudev-215:= )" | ||
RDEPEND="${COMMON_DEPEND} | ||
>=app-cdr/dvdisaster-0.72.4 | ||
media-video/mjpegtools" | ||
DEPEND="${COMMON_DEPEND} | ||
app-arch/zip | ||
app-text/xmlto | ||
sys-devel/gettext | ||
virtual/yacc | ||
virtual/pkgconfig" | ||
|
||
S=${WORKDIR}/${MY_P} | ||
|
||
src_prepare() { | ||
# disable obsolete GNOME 2.x libraries wrt #508854 | ||
sed -i -e '/PKG_CONFIG/s:libgnomeui-2.0:dIsAbLeAuToMaGiC&:' configure || die | ||
# rmdir: failed to remove `tempfoobar': Directory not empty | ||
sed -i -e '/rmdir "$$t"/d' docs/Makefile.in || die | ||
# fix underlinking wrt #367863 | ||
sed -i -e 's:@LIBS@:& -ljpeg:' wxVillaLib/Makefile.in || die | ||
# silence desktop-file-validate QA check | ||
sed -i \ | ||
-e '/Icon/s:.png::' -e '/^Encoding/d' -e '/Categories/s:Application;::' \ | ||
data/dvdstyler.desktop || die | ||
has_version '>=media-video/ffmpeg-2.9' && epatch "${FILESDIR}/ffmpeg29.patch" | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
--docdir=/usr/share/doc/${PF} \ | ||
$(use_enable debug) \ | ||
--with-wx-config=${WX_CONFIG} | ||
} | ||
|
||
src_install() { | ||
default | ||
rm -f "${ED}"/usr/share/doc/${PF}/{COPYING*,INSTALL*} | ||
} |