Skip to content

Commit

Permalink
app-i18n/scim: version bump.
Browse files Browse the repository at this point in the history
Bug: 584494

Package-Manager: portage-2.2.28
  • Loading branch information
heroxbd committed Jun 2, 2016
1 parent cdd5b12 commit e0cdfbe
Show file tree
Hide file tree
Showing 2 changed files with 100 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-i18n/scim/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST scim-1.4.14.tar.gz 1519287 SHA256 e91e4cfed92f3e19d229f702eda03038b3f9a0ce6c4e625b0be51134c19b7678 SHA512 00fe7a1b40b69aae123c0a1e67eb3744ad1e6b1e66726bb011a7426bd28012c52b346c62f08c7ecf0977ac3e88ee416337c9fa89b39142d5eea338d99641f5df WHIRLPOOL cb32326b30ff17ca4815267898de715e50893e77c28a48c55cf708f818fff4aea9e2114f982302c0fd6fd4e1fc45f2ca8490603db0de49ed4159914e1edd516d
DIST scim-1.4.16.tar.gz 1361105 SHA256 54173a4faa50c81c754e46458bb809428a6f4a2fd9e62c9b443648c6953b4cec SHA512 23fe60202d74dd8cba84da40f80b6998d96180b08a618b052dde54b4d16a65246608344f63d6dd9b3d8a98102adcfd4831d850d81348539074273a2062c133d8 WHIRLPOOL 3955cad6eb3d8abf780af76d78f8025a1b8425e1f68df52517d999bd9369980a605ac40c3f7c3812b3b65b2cf7dff55a384238f7adfd689841a83475ed5b09e3
DIST scim-1.4.17.tar.gz 1285383 SHA256 573add90f266b2351a04950fcf0f558459997ea23d0266b43f586acea009f922 SHA512 a7e0696330bca6fdf929ec0565ab4af1b4d0e5f73592cf5cccf1af6412eb351cd5a5ec9a3e5b83b24d6abad89bbb38a375cbbb0fd978f2fa17f6d64b69da0e3a WHIRLPOOL b28d609b306756c352445568e3e2bdbc10e6a89859d671fcca0d3008d3894f53288eff48ec52fb0d3a8244b7803feb89590fc8ba2f3bd0982bab916f904e2150
99 changes: 99 additions & 0 deletions app-i18n/scim/scim-1.4.17.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,99 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils flag-o-matic multilib gnome2-utils autotools

DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
HOMEPAGE="https://sourceforge.net/projects/scim"
SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="doc gtk3"

RDEPEND="x11-libs/libX11
dev-libs/glib:2
gtk3? ( x11-libs/gtk+:3 )
!gtk3? ( x11-libs/gtk+:2 )
>=dev-libs/atk-1
>=x11-libs/pango-1"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen
>=app-text/docbook-xsl-stylesheets-1.73.1 )
dev-lang/perl
virtual/pkgconfig
>=dev-util/intltool-0.33
sys-devel/libtool"
DOCS=(
README
AUTHORS
ChangeLog
docs/developers
docs/scim.cfg
)

src_prepare() {
default
eautoreconf
}

src_configure() {
# bug #83625
filter-flags -fvisibility-inlines-hidden -fvisibility=hidden
econf $(use_with doc doxygen) \
--enable-ld-version-script \
$(usex gtk3 --with-gtk-version={3,2})
}

src_compile() {
default
use doc && emake docs
}

src_install() {
use doc && HTML_DOCS=( "${S}/docs/html/" )
default

sed -e "s:@EPREFIX@:${EPREFIX}:" "${FILESDIR}/xinput-${PN}" > "${T}/${PN}.conf" || die
insinto /etc/X11/xinit/xinput.d
doins "${T}/${PN}.conf"
}

pkg_postinst() {
elog
elog "To use SCIM with both GTK and XIM, you should use the following"
elog "in your user startup scripts such as .gnomerc or .xinitrc:"
elog
elog "LANG='your_language' scim -d"
elog "export XMODIFIERS=@im=SCIM"
elog "export GTK_IM_MODULE=\"scim\""
elog "export QT_IM_MODULE=\"scim\""
elog
elog "where 'your_language' can be zh_CN, zh_TW, ja_JP.eucJP or any other"
elog "UTF-8 locale such as en_US.UTF-8 or ja_JP.UTF-8"
elog
elog "To use Chinese input methods:"
elog " # emerge app-i18n/scim-tables app-i18n/scim-pinyin"
elog "To use Korean input methods:"
elog " # emerge app-i18n/scim-hangul"
elog "To use Japanese input methods:"
elog " # emerge app-i18n/scim-anthy"
elog "To use various input methods (more than 30 languages):"
elog " # emerge app-i18n/scim-m17n"
elog
elog "Please modify ${EPREFIX}/etc/scim/global and add your UTF-8 locale to"
elog "/SupportedUnicodeLocales entry."
elog
ewarn
ewarn "If you upgraded from scim-1.2.x or scim-1.0.x, you should remerge all SCIM modules."
ewarn

gnome2_query_immodules_gtk2
}

pkg_postrm() {
gnome2_query_immodules_gtk2
}

0 comments on commit e0cdfbe

Please sign in to comment.