Skip to content

Commit

Permalink
dev-ruby/time: add 0.4.0
Browse files Browse the repository at this point in the history
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Sep 6, 2024
1 parent 3d72691 commit e0d2bee
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/time/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST time-0.2.2.tar.gz 26129 BLAKE2B 9d7c507c06fca17c9a2734f1116524344518635562b0ba924cdf5e0b0b52cb31f6dffa7aa3c8c06e0d2f5f2c1ffdcef2a92756cd915822be6a1510f08fa91c56 SHA512 4866cd7df233222ed76cf3b35c842b6e1652b429aa15609bfe40f89683ad5df2ce7f37f41dfb0e85f610f2ebf4e431ea8046d67c3aed7aa345d928fe33ba1ae3
DIST time-0.3.0.tar.gz 15520 BLAKE2B 05d30c8dd6da8544fe89e1f92a94d91adf198712acc236703947abef86c9ceefeedc2bc78150d3d1918b29972509c927510fea2e4bfec0a01ad12aa751e27fc2 SHA512 17483eebbddd3be40f83b35813ef5faa3b3fe695e3c13e4cc6d13579b64fd5d1637e2aca2f5e60192b4de6ae761efaa76aa6a6cbbcce7bade31f5f415f224b70
DIST time-0.4.0.tar.gz 16721 BLAKE2B d1f86380c7c79b05f9174bb103c5c69d3abdd9c65b60c65ea4de0d93715a5dc7b2f4cdb8cce9a2d75512c00485b687bbc79bba45389ea12a78ca3776512e45dc SHA512 c95c1167a305fbdf6d138143afc2b822972614b26d87c323d62e663994beb80d12e26e17dc33fe515b65076c50aa05c1d80bc13b6bc83b481d967c796b7c84be
35 changes: 35 additions & 0 deletions dev-ruby/time/time-0.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"

RUBY_FAKEGEM_BINWRAP=""
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_GEMSPEC="time.gemspec"

inherit ruby-fakegem

DESCRIPTION="Extends the Time class with methods for parsing and conversion"
HOMEPAGE="https://github.com/ruby/time"
SRC_URI="https://github.com/ruby/time/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="test"

ruby_add_rdepend "dev-ruby/date"

ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/test-unit-ruby-core )"

all_ruby_prepare() {
sed -e 's/__dir__/"."/' \
-e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
-e 's/git ls-files -z/find * -print0/' \
-i ${RUBY_FAKEGEM_GEMSPEC} || die
}

each_ruby_test() {
${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
}

0 comments on commit e0d2bee

Please sign in to comment.