forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-kids/tuxtype: Bump to 1.8.3, fix use of games group
Suggested-by: maurerpe Closes: https://bugs.gentoo.org/658814 Package-Manager: Portage-2.3.79, Repoman-2.3.17 Signed-off-by: James Le Cuirot <[email protected]>
- Loading branch information
Showing
3 changed files
with
67 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST tuxtype-1.8.1.tar.gz 11470321 BLAKE2B 13650d319e75ed9770113475841780c3413b1d9918f9641bb5b32cf67a622ab731c54149e52252f69030ab8e016b4de408a835aaed29cbf5772213b58cab3e65 SHA512 c7285ece93168260215e20cb5e4f4a46da00687c22241e70f97f735e19501ea8f1abb38e4070fac108c524e5aa3f23f680acef6ef9f5654bc2dab954bcadab01 | ||
DIST tuxtype-1.8.3.tar.gz 11805625 BLAKE2B f34b2386234001452a3aba8afda7206a6bf674e6e60d5e5a8ea889e462f6979615f46bd47d62353c75e814c785e6a2ce97728f8cef6c44e43bb799b633ca0175 SHA512 7638cf7b5cb3a02072d36b43d385e43797bb846c5a69fda532432fb80ece19c44ca7b9b54bd73d4d3b7462b18f90cadb4648ed82a1d9e4822d7f3bd2c7a89343 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
diff -Naur a/Makefile.am b/Makefile.am | ||
--- a/Makefile.am 2014-08-20 04:47:21.000000000 +0100 | ||
+++ b/Makefile.am 2019-11-26 21:12:23.430972975 +0000 | ||
@@ -49,7 +49,6 @@ | ||
$(MKDIR_P) -m 2755 $(DESTDIR)$(pkglocalstatedir) | ||
$(MKDIR_P) -m 2755 $(DESTDIR)$(pkglocalstatedir)/words | ||
# chown root:games $(DESTDIR)$(pkglocalstatedir) | ||
- chown root:games $(DESTDIR)$(pkglocalstatedir)/words | ||
|
||
|
||
uninstall-hook: |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,55 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit autotools desktop xdg | ||
|
||
DESCRIPTION="Typing tutorial with lots of eye-candy" | ||
HOMEPAGE="https://github.com/tux4kids/tuxtype" | ||
SRC_URI="https://github.com/tux4kids/${PN}/archive/upstream/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2 OFL-1.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="svg" | ||
|
||
DEPEND="acct-group/gamestat | ||
media-libs/libsdl[video] | ||
media-libs/sdl-image | ||
media-libs/sdl-mixer | ||
media-libs/sdl-pango | ||
media-libs/sdl-ttf | ||
svg? ( gnome-base/librsvg:2 )" | ||
|
||
RDEPEND="${DEPEND}" | ||
|
||
S="${WORKDIR}/${PN}-upstream-${PV}" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${PN}-1.8.3-games-group.patch | ||
) | ||
|
||
src_prepare() { | ||
xdg_src_prepare | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
--localedir="${EPREFIX}"/usr/share/locale \ | ||
$(use_with svg rsvg) | ||
} | ||
|
||
src_install() { | ||
emake install DESTDIR="${D}" | ||
rm -v "${ED}"/usr/share/doc/${PF}/{ABOUT-NLS,COPYING,INSTALL} || die | ||
keepdir /etc/${PN} /var/lib/${PN}/words | ||
|
||
newicon -s 64 icon.png ${PN}.png | ||
make_desktop_entry ${PN} TuxTyping | ||
|
||
fowners root:gamestat /var/lib/${PN} /usr/bin/${PN} | ||
fperms 660 /var/lib/${PN} | ||
fperms 2755 /usr/bin/${PN} | ||
} |