Skip to content

Commit

Permalink
sci-geosciences/osm2pgsql: Version bump to 0.94.0
Browse files Browse the repository at this point in the history
Gentoo-Bug: 634086
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
titanofold committed Oct 14, 2017
1 parent ae5a9c2 commit e15c545
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-geosciences/osm2pgsql/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST osm2pgsql-0.92.0.tar.gz 1364481 SHA256 b741cfdf6489fd5def721f75a9558b8cda53165dda7ca9548fcc5b43e163ee77 SHA512 fc2afd6c06f8a44ce3c75e3a731d48cefa17b406c296208519f598531cb3d9561fcfd09c69bc20753ba7e9440087f3f5d38bfe117ab222d8b10987a8d3165ae8 WHIRLPOOL 4fd5d1c645e173f018618edb9fd49da692637fb59a9ccac13ddbef74003fd776af669f23fa2346bb33be2c7d89e121cc206892d18bd2c123debef032827ee45f
DIST osm2pgsql-0.94.0.tar.gz 1203310 SHA256 9e67e400deca48185313921431884171fb087dfe9e0d21e31857b8b06f20d317 SHA512 eceb5de7679048f51a9ad1be4ecf5b2d26da827b3eb8d6b0e86657603c8bf8a6f8d6f665c8ff8db91070a2966057f2deed5e4a3cc8bfb28e60a6031454e4758e WHIRLPOOL 2ebc7f0c09079a9417f7c67b7c2fa8ea275b35f20df9cbfed1c9223d7ee1385af9313c6fc3c165ef410b7480517333284921e2e46c0e2706d318cb21d0761b3b
41 changes: 41 additions & 0 deletions sci-geosciences/osm2pgsql/osm2pgsql-0.94.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils

DESCRIPTION="Converts OSM data to SQL and insert into PostgreSQL db"
HOMEPAGE="https://wiki.openstreetmap.org/wiki/Osm2pgsql https://github.com/openstreetmap/osm2pgsql"
SRC_URI="https://github.com/openstreetmap/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+lua"

COMMON_DEPEND="
app-arch/bzip2
dev-db/postgresql:=
dev-libs/expat
sci-libs/proj
sys-libs/zlib
lua? ( dev-lang/lua:= )
"
DEPEND="${COMMON_DEPEND}
dev-libs/boost
"
RDEPEND="${COMMON_DEPEND}
dev-db/postgis
"

# Tries to connect to local postgres server and other shenanigans
RESTRICT="test"

src_configure() {
local mycmakeargs=(
-DWITH_LUA=$(usex lua)
-DBUILD_TESTS=OFF
)
cmake-utils_src_configure
}

0 comments on commit e15c545

Please sign in to comment.