Skip to content

Commit

Permalink
dev-java/netty-common: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Oct 1, 2015
1 parent c1384fb commit e16798d
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/netty-common/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST netty-4.0.21.Final.tar.gz 960489 SHA256 e1b5572defaa760dcd8ded4d7691e9daf242b2e1885115b722f2f790d9ef9f75 SHA512 5d432e9e433c22b82e67ed3463c6982ca95c2ad823165e1ca9a5046e598878f06aac4221be235f2bda15edfdb22028f2a4f74fb37d431f24a2636e4ec60fae74 WHIRLPOOL 92e96986def775f26286958a9e2c7fe55ab571ad373f9cc25357db71f85f170d7aba7d7854c130c5788f7332665000cd10f666fff06abd0ce57cf4f95008958a
DIST netty-4.0.22.Final.tar.gz 983956 SHA256 d539483235223804d76f8da572b851cd196254f5da7d3ac8e064c626b31748ff SHA512 f216c8431e663533ea5258bc054154d07f791667712c4dd619eae5de55c1b9031cca756a26b49d8a0bb9e3cf61ca5cb295e7a3b3e4e9e98e99cd53963d54912e WHIRLPOOL ca3d9a9b78643414b4361388e8486ab7cbb7d4a479718d89a8f51d90ef7fd580b154f09d1e8014503bececd49fb8841782e933c8cc8f355609ccae1f6510ccc5
46 changes: 46 additions & 0 deletions dev-java/netty-common/netty-common-4.0.22.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

JAVA_PKG_IUSE="doc source"

inherit java-pkg-2 java-pkg-simple

MY_PN="netty"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Async event-driven framework for rapid development of high performance network applications"
HOMEPAGE="http://netty.io/"
SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/${MY_P}.Final.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"

CDEPEND="dev-java/commons-logging:0
dev-java/javassist:3
dev-java/log4j:0
dev-java/slf4j-nop:0
dev-java/slf4j-api:0"
RDEPEND=">=virtual/jre-1.7
${CDEPEND}"
DEPEND=">=virtual/jdk-1.7
${CDEPEND}"

S="${WORKDIR}/${MY_PN}-${MY_P}.Final/${PN/${MY_PN}-}"

JAVA_GENTOO_CLASSPATH="
log4j
slf4j-api
slf4j-nop
javassist-3
commons-logging"

JAVA_SRC_DIR="src/main/java"

# Tests fail as they might need logging to be properly set up and/or compatible.
#
# junit.framework.AssertionFailedError: expected:<[foo]> but was:<[NOP]>
# at io.netty.util.internal.logging.Slf4JLoggerFactoryTest.testCreation
RESTRICT="test"

0 comments on commit e16798d

Please sign in to comment.