Skip to content

Commit

Permalink
dev-python/parsedatetime: Add missing dependency on dev-python/future
Browse files Browse the repository at this point in the history
Gentoo-Bug: #621182
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
mrueg committed Jun 12, 2017
1 parent ffa91f9 commit e1bfa05
Showing 1 changed file with 28 additions and 0 deletions.
28 changes: 28 additions & 0 deletions dev-python/parsedatetime/parsedatetime-2.4-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})

inherit distutils-r1

DESCRIPTION="Parse human-readable date/time strings"
HOMEPAGE="https://github.com/bear/parsedatetime"
SRC_URI="https://github.com/bear/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="test"

RDEPEND="dev-python/future[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"

python_prepare() {
rm setup.cfg || die
}

python_test() {
py.test || die
}

0 comments on commit e1bfa05

Please sign in to comment.