Skip to content

Commit

Permalink
dev-libs/libgit2-glib: Bump to 0.26.2
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Dec 2, 2017
1 parent 5e6af07 commit e1c30c6
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libgit2-glib/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST libgit2-glib-0.24.4.tar.xz 458360 SHA256 3a211f756f250042f352b3070e7314a048c88e785dba9d118b851253a7c60220 SHA512 55874f77ded1474eab6f84d3426c8cddd56a42b04b8b3e50e4294f396b8c10025a38bc925c0b74ba3e52022c696f07e7f69b75c443bbd0af0f9e0769b7c4555f WHIRLPOOL 22a17e940a670ccb31cf0fc229b8f042794e10e7c5996d4059779d3a7b2ab5865b9cf1bc1a32a9297e88e5b069b281e7f20b2db636f91d5f8af9df8f14d23346
DIST libgit2-glib-0.25.0.tar.xz 420500 SHA256 4a256b9acfb93ea70d37213a4083e2310e59b05f2c7595242fe3c239327bc565 SHA512 f265d5da4bba28de2aa7254d36fa596b9e348c6543cd559cbb9c1f9610d4b63af00c82fb4138f345e15109503e0d61101d3344c68539348cb268403387a4418e WHIRLPOOL beb276d2637edca19a96f7eca94bc8b318b31e6c014044e7526c9c397ec376dea38891eb0985351899ad26de1436f4713e3ac0d708966e4e41d41d516208072f
DIST libgit2-glib-0.26.0.tar.xz 420404 SHA256 06b16cfcc3a53d9804858618d690e5509e9af2e2245b75f0479cadbbe39745c3 SHA512 322f99b6273f0e56fcccdccd3b1193e1b62ca9dd495144e7c5fc59520dd693b1ceea4bab7335de1201ab09ecd7e146daa86afd9256d16649c144adb0b6de97c6 WHIRLPOOL 2bee4c44eae4ac01abd65d1b9a48069a60b749e86101d1df483a5b13a0aa3380756bb083b33801b4787ed384bc7fa7ed5de53271a7dcc95b09fa7f296b5060c1
DIST libgit2-glib-0.26.2.tar.xz 421956 BLAKE2B d38698f00d85b484d17078e78ad051a4c068b87df73fcf4d7b852dc6966628580cc4e5b3899a6edd5dc29fb47ef97ebe2c458992701b7642549f3e411d917dc5 SHA512 35fb3ec7a3757212f53cc884760f69725beff8462018b8e716fad389ba57d1acba99ece0fcd148ff40dc63e1fc7e7d566fe84759bd88d3a0ff9fdf970b0a5563
58 changes: 58 additions & 0 deletions dev-libs/libgit2-glib/libgit2-glib-0.26.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python{3_4,3_5,3_6} )
VALA_USE_DEPEND="vapigen"

inherit gnome2 python-r1 vala

DESCRIPTION="Git library for GLib"
HOMEPAGE="https://wiki.gnome.org/Projects/Libgit2-glib"

LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="python +ssh +vala"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

# Specify libgit2 dependency with subslot because libgit2 upstream has a habit
# of changing their API in each release in ways that break libgit2-glib
RDEPEND="
>=dev-libs/gobject-introspection-0.10.1:=
>=dev-libs/glib-2.44.0:2
>=dev-libs/libgit2-0.26.0:0/26[ssh?]
python? (
${PYTHON_DEPS}
dev-python/pygobject:3[${PYTHON_USEDEP}] )
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.11
virtual/pkgconfig
vala? ( $(vala_depend) )
"

src_prepare() {
use vala && vala_src_prepare
gnome2_src_prepare
}

src_configure() {
gnome2_src_configure \
$(use_enable python) \
$(use_enable ssh) \
$(use_enable vala)
}

src_install() {
gnome2_src_install

if use python ; then
install_gi_override() {
python_moduleinto "$(python_get_sitedir)/gi/overrides"
python_domodule "${S}"/${PN}/Ggit.py
}
python_foreach_impl install_gi_override
fi
}

0 comments on commit e1c30c6

Please sign in to comment.