Skip to content

Commit

Permalink
media-libs/libsoundio: version bump to 1.0.2
Browse files Browse the repository at this point in the history
  • Loading branch information
diogocp committed Oct 2, 2015
1 parent cfe68b5 commit e1d0962
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/libsoundio/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libsoundio-1.0.0.tar.gz 112139 SHA256 f05d87916266b6b32020c3e13b78ce9f3a758c43c8f8c8bbaf37578d99e1d3e2 SHA512 d0a0eda701d99ef658ee2858dbf4be2ec872d74bc1c9d05ed5484adcc17e774530c150fcd86cd1213a8dceb6373dfd3319a2c97c506ada0cdfe0f02551c0ddd0 WHIRLPOOL 1720e8eb64dc407a17dfbc9ccc8406184e0fa8c5bcc799553e5af181c9faebc0d0ba75fab0c8d9f6332fec6db1711ae9d6afe4be0e970fd5e9b526511b0a8965
DIST libsoundio-1.0.2.tar.gz 114311 SHA256 821fc5b94880f09f57178ea7b474216e7dd0d698c8cac98e366d28d3b4f3ac4d SHA512 9110c6dd2f2ee8ed9f4a454b92aea5292b1b222aebe6851d247e964a6aa80f1d95d490e2d3da5d06cbd6853407c4002f02d163fac5631f51e110d57a9b58faa3 WHIRLPOOL 1e82ddf04c42e64e1bc19519ab07265ebd0f56ac2f32bb83ab4710e61cdfaa392ee5103c2a9a23c3a8f71be93cb713b2a4356b07ba03e1e5957f0b7e3b517dff
36 changes: 36 additions & 0 deletions media-libs/libsoundio/libsoundio-1.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit cmake-multilib

DESCRIPTION="C99 library providing cross-platform audio input and output"
HOMEPAGE="http://libsound.io/"
SRC_URI="http://libsound.io/release/${P}.tar.gz"

LICENSE="MIT"
SLOT="0/1"
KEYWORDS="~amd64"
IUSE="alsa coreaudio examples pulseaudio static-libs"

DEPEND="alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )"
RDEPEND="${DEPEND}"

# ENABLE_JACK does not support the current version of jack1
# See https://github.com/andrewrk/libsoundio/issues/11
multilib_src_configure() {
local mycmakeargs=(
-DENABLE_ALSA=$(usex alsa)
-DENABLE_COREAUDIO=$(usex coreaudio)
-DENABLE_JACK=no
-DENABLE_PULSEAUDIO=$(usex pulseaudio)
-DENABLE_WASAPI=no
-DBUILD_STATIC_LIBS=$(usex static-libs)
-DBUILD_EXAMPLE_PROGRAMS=$(multilib_native_usex examples)
-DBUILD_TESTS=no
)
cmake-utils_src_configure
}

0 comments on commit e1d0962

Please sign in to comment.