Skip to content

Commit

Permalink
sys-kernel/vanilla-kernel: Bump to 5.4.29
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Apr 2, 2020
1 parent e9d55db commit e1f3973
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-kernel/vanilla-kernel/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,6 +5,7 @@ DIST linux-4.19.92-arch1.amd64.config 222487 BLAKE2B a658d80d85525287a1df9053ca2
DIST linux-5.4.24.arch1.amd64.config 241418 BLAKE2B b24fbeb04cb63b5f0ec7ea935b21302aec92552f1a8108c204f8529803d5eb23dc6124529ca0f9fc394af051b0d3725698fb5df95d6af25274cb51146e3c052b SHA512 d180f3cea5c9c357d482d8533dec7e641b782f501c15f749a5a5347fe737fab93a43a95e12391fcbe3d93a90d673c91b890cb66d219a8f8247074d222959e9cd
DIST linux-5.4.24.arch1.i686.config 240684 BLAKE2B 8c29d083cef61f0c61e7256553c00817c5656ff56929dbce60132283a1a43576b18c42823eec7114c9332caad59557b1383a8f9fd16c92ff54f87e587fb2fe06 SHA512 bc293ffd03ee0d8dbe745e80963d3f52977c1cd5875826afa0be6d4615aa33afc6a8a548bd5db5d3bc00a33f7cde566206a959d4f5ea4b4f41ed83492ae4e365
DIST linux-5.4.27.tar.xz 109496824 BLAKE2B 7375def01b7402f3abe7c54b5e0bd318e712c867ef8799c9b64418c57f72be2b88c3aa609054b0832643f4779e338cabeea297be2b376263b48f0d1b5c319883 SHA512 86bd2ea097075417daa98ae1da5677933d0e22342af79f0f442943d44cc0a2f02905bb60a48b803f70ef542dd4647246fc151573dd052f35954d8c0a159ee0e9
DIST linux-5.4.29.tar.xz 109503036 BLAKE2B 22db7d171058a2a9dc86c33d918691c8bcf1dae3111c7644194ca660a6118469829773d24514fc72081d2ff54b43bcd178033473a7ec9d9b252b37a82ad06e4f SHA512 ac296004bb852db37d7d6da030d1b7367a90e7933cf99680f7ddefb29238514c56d3a5c2af90b51559d1f0708edc01b899da0e24e5190c07ee26b8696e989594
DIST linux-5.5.11.tar.xz 110743096 BLAKE2B 7fde5515b48d05d87a04818eec3404031ac7c3910620c3ce76769c546d92f34112f1cff9ef5953be3b344b1230d45715556aa39852d3ef04db67345deba7423f SHA512 86e86120777eecb66ce2a6cb80c5f0c3fd184eaadcb82bc5d6076a0eddd8548e83a5ef459ca26d785bf29245a240a4fc81913bbe75fc9868418b8981b67dba73
DIST linux-5.5.5-arch1.amd64.config 243885 BLAKE2B 088e76a9981a64cd6163667fd09cc02148f15cc53812a429d1f5e22dc893823f57041e581ec957f38504c1fbb5aa0c7886847d1ea4cdc44d5ab245dcc304edc3 SHA512 e6958e1fd35e2a900fa6c81e68e35b42496e245829b8bfd85d9d351dcdf8bbea93d25a0edf74871beababb4ba28cd7a731e589e68e047ac972d973ea8c20d3ac
DIST linux-5.5.6-arch1.i686.config 243301 BLAKE2B c5fdd9dc2a0baed1ea421faa8f254d6ece47e89b78fc4c25c38369b53acc1f954978f2f86eda23b77d20a35096a596944f9c433db66008278ed2b8140823ce62 SHA512 b2d75bb1826a4dfad10aa5b6fa9cce2684d5de2dabc6da165e192e5a33cbd6eeaff4d7f236e074f4c099830e01e767bd6bc14a70d644057dce59288ae9704877
Expand Down
65 changes: 65 additions & 0 deletions sys-kernel/vanilla-kernel/vanilla-kernel-5.4.29.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit kernel-build

MY_P=linux-${PV}
# https://git.archlinux.org/svntogit/packages.git/log/trunk/config?h=packages/linux-lts
AMD64_CONFIG_VER=5.4.24.arch1
AMD64_CONFIG_HASH=c060a2f4e686e06679d9cf9bbab5fdf423e5a402
# https://git.archlinux32.org/packages/log/core/linux-lts/config
I686_CONFIG_VER=5.4.24.arch1
I686_CONFIG_HASH=3f4ba0851a9e9a3809fdec4091335182b0f1885a

DESCRIPTION="Linux kernel built from vanilla upstream sources"
HOMEPAGE="https://www.kernel.org/"
SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
amd64? (
https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux-lts&id=${AMD64_CONFIG_HASH}
-> linux-${AMD64_CONFIG_VER}.amd64.config
)
x86? (
https://git.archlinux32.org/packages/plain/core/linux-lts/config?id=${I686_CONFIG_HASH}
-> linux-${I686_CONFIG_VER}.i686.config
)"
S=${WORKDIR}/${MY_P}

LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"

RDEPEND="
!sys-kernel/vanilla-kernel-bin:${SLOT}"

src_prepare() {
default

# prepare the default config
case ${ARCH} in
amd64)
cp "${DISTDIR}"/linux-${AMD64_CONFIG_VER}.amd64.config .config || die
;;
x86)
cp "${DISTDIR}"/linux-${I686_CONFIG_VER}.i686.config .config || die
;;
*)
die "Unsupported arch ${ARCH}"
;;
esac

local config_tweaks=(
# shove arch under the carpet!
-e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
# we do support x32
-e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
# disable signatures
-e '/CONFIG_MODULE_SIG/d'
-e '/CONFIG_SECURITY_LOCKDOWN/d'
# disable compression to allow stripping
-e '/CONFIG_MODULE_COMPRESS/d'
# disable gcc plugins to unbreak distcc
-e '/CONFIG_GCC_PLUGIN_STRUCTLEAK/d'
)
sed -i "${config_tweaks[@]}" .config || die
}

0 comments on commit e1f3973

Please sign in to comment.