Skip to content

Commit

Permalink
dev-util/cccc: [QA] fix tc-get* quoting
Browse files Browse the repository at this point in the history
This can cause build problems for e.g. 32-bit (gcc -m32 ...)

Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Mar 20, 2022
1 parent b520d78 commit e27d6c8
Show file tree
Hide file tree
Showing 2 changed files with 10 additions and 10 deletions.
10 changes: 5 additions & 5 deletions dev-util/cccc/cccc-3.1.5-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -35,16 +35,16 @@ src_prepare() {
src_compile() {
tc-export CC CXX LD AS AR NM RANLIB STRIP OBJCOPY
if use debug ; then
DEBUG="true" emake -j1 CCC=$(tc-getCXX) CC=$(tc-getCC) cccc
DEBUG="true" emake -j1 CCC="$(tc-getCXX)" CC="$(tc-getCC)" cccc
else
emake -j1 CCC=$(tc-getCXX) CC=$(tc-getCC) cccc
emake -j1 CCC="$(tc-getCXX)" CC="$(tc-getCC)" cccc
fi

use apidoc && emake -j1 CCC=$(tc-getCXX) metrics docs
use apidoc && emake -j1 CCC="$(tc-getCXX)" metrics docs
}

src_test() {
emake -j1 CCC=$(tc-getCXX) test
emake -j1 CCC="$(tc-getCXX)" test
}

src_install() {
Expand Down
10 changes: 5 additions & 5 deletions dev-util/cccc/cccc-3.1.6.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -35,16 +35,16 @@ src_prepare() {
src_compile() {
tc-export CC CXX LD AS AR NM RANLIB STRIP OBJCOPY
if use debug ; then
DEBUG="true" emake -j1 CCC=$(tc-getCXX) CC=$(tc-getCC) cccc
DEBUG="true" emake -j1 CCC="$(tc-getCXX)" CC="$(tc-getCC)" cccc
else
emake -j1 CCC=$(tc-getCXX) CC=$(tc-getCC) cccc
emake -j1 CCC="$(tc-getCXX)" CC="$(tc-getCC)" cccc
fi

use apidoc && emake -j1 CCC=$(tc-getCXX) metrics docs
use apidoc && emake -j1 CCC="$(tc-getCXX)" metrics docs
}

src_test() {
emake -j1 CCC=$(tc-getCXX) test
emake -j1 CCC="$(tc-getCXX)" test
}

src_install() {
Expand Down

0 comments on commit e27d6c8

Please sign in to comment.