Skip to content

Commit

Permalink
media-libs/opusfile: add libressl support
Browse files Browse the repository at this point in the history
  • Loading branch information
Julian Ospald committed Oct 5, 2015
1 parent 1be5536 commit e27dccc
Showing 1 changed file with 36 additions and 0 deletions.
36 changes: 36 additions & 0 deletions media-libs/opusfile/opusfile-0.6-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

DESCRIPTION="A high-level decoding and seeking API for .opus files"
HOMEPAGE="http://www.opus-codec.org/"
SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc fixed-point +float +http libressl static-libs"

RDEPEND="media-libs/libogg
media-libs/opus
http? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
)"

DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"

REQUIRED_USE="^^ ( fixed-point float )"

src_configure() {
econf \
--docdir=/usr/share/doc/${PF} \
$(use_enable doc) \
$(use_enable fixed-point)\
$(use_enable float) \
$(use_enable http) \
$(use_enable static-libs static)
}

0 comments on commit e27dccc

Please sign in to comment.