Skip to content

Commit

Permalink
dev-ruby/racc: add 1.6.2
Browse files Browse the repository at this point in the history
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Dec 24, 2022
1 parent c9ffcd4 commit e2c2df0
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/racc/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST racc-1.4.16.tar.gz 451711 BLAKE2B d3bcb72a69df255d5468054541c281bf7bd3225eb
DIST racc-1.5.2.tar.gz 434903 BLAKE2B cfbaa09c1b2e233e82228075cf979c54688e51e702cade072d42b2952100b74a53e536d904cbbf15cb04ffc74018b48e5b27a5773adf6240614c815250d47119 SHA512 73c68dd75fa35727fd93a76886dd77afbb7032271e535c6e885a4ede6822052a93a610dec8a1f84daf24903c749b30a185831ec96d651588db2a2524f3dcd477
DIST racc-1.6.0.tar.gz 470565 BLAKE2B 482b17723630dfb1d6e010c3eeb7da5a9f7b97f544d1a5020195134cd5446d28eff9a75b6c392a75970ddf024f560d2c7135abc4a2de76b581aa835c0901b524 SHA512 c19b7444bfafa0dfe3448600d10a1a09319702c37632e19569aeb947e7c035cc4067da040d45ede0dab35eaa197a55eac394715aae520fba41ed6e0c01c95e3d
DIST racc-1.6.1.tar.gz 470769 BLAKE2B 285959593b60a5883c6f6ed119832c027a28fe43238721eb2365c1871635d781be73ea5a8d53593e288745906f068a8a5e9f568181b210374cc943cc35da5b7b SHA512 bbd592eee9c015ece87c555d4546a36d2a60bd6b9559ae1f3ca4d1cff887738bee46dbb32010d87d71fe4dbe0a13d00fb392db540f6c4b64688f9a8387ca20c7
DIST racc-1.6.2.tar.gz 470740 BLAKE2B c21e01cd7a11573774218ba97de3f58ebdbc4b138def4dfb2620b626d68e71a72f66a7e7f7644707942d4ec5f387b848aa00aa1d7dd81fc98f50b1c23ce118cb SHA512 ef577d0da440361702d15cf2127142e57d5af4146f120cd9d94ee8c8b4380810c8913c373a9969f09b50e0850a8ac04ffd22729c4abdab0670765c7379b549f6
54 changes: 54 additions & 0 deletions dev-ruby/racc/racc-1.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

USE_RUBY="ruby27 ruby30 ruby31"

RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="README.rdoc README.ja.rdoc TODO ChangeLog"

RUBY_FAKEGEM_GEMSPEC="racc.gemspec"

RUBY_FAKEGEM_EXTENSIONS=(ext/racc/cparse/extconf.rb)
RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/racc/cparse"

inherit ruby-fakegem

DESCRIPTION="A LALR(1) parser generator for Ruby"
HOMEPAGE="https://github.com/tenderlove/racc"
SRC_URI="https://github.com/tenderlove/racc/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"

KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="doc test"

ruby_add_rdepend "virtual/ruby-ssl"

ruby_add_bdepend "dev-ruby/rake
test? ( dev-ruby/minitest )"

all_ruby_prepare() {
sed -i -e 's/, :isolate//' Rakefile || die
sed -i -e '/bundler/ s:^:#:' -e '/rdoc/,/^end/ s:^:#:' Rakefile || die

# Avoid depending on rake-compiler since we don't use it to compile
# the extension.
sed -i -e '/rake-compiler/ s:^:#:' -e '/extensiontask/ s:^:#:' Rakefile
sed -i -e '/ExtensionTask/,/^ end/ s:^:#:' Rakefile
# Which means we need to generate the parser file here
rake lib/racc/parser-text.rb || die

sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
}

all_ruby_install() {
all_fakegem_install

dodoc -r doc

docinto examples
dodoc -r sample
}

0 comments on commit e2c2df0

Please sign in to comment.