forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/cinnamon-control-center: Version bump
Package-Manager: portage-2.3.0_rc1
- Loading branch information
Showing
2 changed files
with
94 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST cinnamon-control-center-2.8.1.tar.gz 4090162 SHA256 595076ef89949c31357cd45f41818df1f6b7350a2b810f107e0b88cd9870e273 SHA512 e0f21bc29128b56d2024ea5bd9dff70a917259437804f4aad0942ee1313090b70e6811d1b54513b4639c0bff0230efcb2847a42fcf9ad183b24a3cbfeda976de WHIRLPOOL 47d3255eeddd782fb5c87ff82ed5d8ab8588b8066b9da9344abcfa259d0b481e06f676cefa43563f28ddc75d2c8112b30712b4ae52f750e03f779b1a73108c7b | ||
DIST cinnamon-control-center-3.0.1.tar.gz 3834138 SHA256 3d9f0eb45168a91101f99452b38184dd6417dd89064be4523e565bd721a521fe SHA512 97f726cddb12afd697a542bf40b89c84e8256cc7e1bff31eaf3ed86ba9ffe23660085e4e4123f955f1aa4aa31930b209c2a26649f2dec55d10a4803d86942e46 WHIRLPOOL 68f0d2292d4fa43de31d9ed8cf4d15f1fc887e26ebc7c21cfec9c180ca01f6b7b11be0e88c5a4f2f84b35c2a6162565cb5b8eb647d563d8cd939e700dc76f4ff |
93 changes: 93 additions & 0 deletions
93
gnome-extra/cinnamon-control-center/cinnamon-control-center-3.0.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,93 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
GNOME2_LA_PUNT="yes" # gmodule is used, which uses dlopen | ||
|
||
inherit autotools eutils gnome2 | ||
|
||
DESCRIPTION="Cinnamons's main interface to configure various aspects of the desktop" | ||
HOMEPAGE="http://cinnamon.linuxmint.com/" | ||
SRC_URI="https://github.com/linuxmint/cinnamon-control-center/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
IUSE="+colord +cups debug input_devices_wacom" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
# False positives caused by nested configure scripts | ||
QA_CONFIGURE_OPTIONS=".*" | ||
|
||
# FIXME: modemmanager is not optional | ||
# networkmanager is not optional | ||
|
||
COMMON_DEPEND=" | ||
>=dev-libs/glib-2.31:2 | ||
>=gnome-base/libgnomekbd-2.91.91:0= | ||
>=gnome-extra/cinnamon-desktop-1.0:0= | ||
>=gnome-extra/cinnamon-menus-1.0:0= | ||
>=gnome-extra/cinnamon-settings-daemon-1.0:0= | ||
>=gnome-extra/nm-applet-0.9.8 | ||
media-libs/fontconfig | ||
>=net-misc/modemmanager-0.7 | ||
>=net-misc/networkmanager-0.9.8[modemmanager] | ||
>=sys-auth/polkit-0.103 | ||
>=x11-libs/gdk-pixbuf-2.23.0:2 | ||
>=x11-libs/gtk+-3.4.1:3 | ||
>=x11-libs/libnotify-0.7.3:0= | ||
x11-libs/libX11 | ||
x11-libs/libxklavier | ||
colord? ( >=x11-misc/colord-0.1.14:0= ) | ||
cups? ( >=net-print/cups-1.4[dbus] ) | ||
input_devices_wacom? ( | ||
>=dev-libs/libwacom-0.7 | ||
>=x11-libs/gtk+-3.8:3 | ||
>=x11-libs/libXi-1.2 ) | ||
" | ||
# <gnome-color-manager-3.1.2 has file collisions with g-c-c-3.1.x | ||
# libgnomekbd needed only for gkbd-keyboard-display tool | ||
RDEPEND="${COMMON_DEPEND} | ||
|| ( >=sys-apps/systemd-31 ( app-admin/openrc-settingsd sys-auth/consolekit ) ) | ||
x11-themes/adwaita-icon-theme | ||
colord? ( >=gnome-extra/gnome-color-manager-3 ) | ||
cups? ( | ||
app-admin/system-config-printer | ||
net-print/cups-pk-helper ) | ||
input_devices_wacom? ( gnome-extra/cinnamon-settings-daemon[input_devices_wacom] ) | ||
" | ||
|
||
DEPEND="${COMMON_DEPEND} | ||
app-text/iso-codes | ||
x11-proto/xproto | ||
x11-proto/xf86miscproto | ||
x11-proto/kbproto | ||
dev-libs/libxslt | ||
>=dev-util/intltool-0.40.1 | ||
>=sys-devel/gettext-0.17 | ||
virtual/pkgconfig | ||
gnome-base/gnome-common | ||
" | ||
# Needed for autoreconf | ||
# gnome-base/gnome-common | ||
|
||
src_prepare() { | ||
# make some panels optional | ||
eapply "${FILESDIR}"/${PN}-2.8.0-optional.patch | ||
eautoreconf | ||
gnome2_src_prepare | ||
} | ||
|
||
src_configure() { | ||
# --enable-systemd doesn't do anything in $PN-2.2.5 | ||
gnome2_src_configure \ | ||
--disable-static \ | ||
--enable-documentation \ | ||
--without-libsocialweb \ | ||
$(use_enable colord color) \ | ||
$(use_enable cups) \ | ||
$(usex debug --enable-debug=yes ' ') \ | ||
$(use_enable input_devices_wacom wacom) | ||
} |