forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
drop doc useflag since generation is broken Bug: https://bugs.gentoo.org/573218 Package-Manager: Portage-2.3.13, Repoman-2.3.3 Signed-off-by: Michael Orlitzky <[email protected]>
- Loading branch information
1 parent
0bfbd78
commit e2e8840
Showing
2 changed files
with
33 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST awl-0.56.tar.gz 769208 BLAKE2B 08513675d8d26fab26429a6e51cfd7dc3b00aa7cec6538789e6bbd2853989bf563ffba0df3cda61359f30ab672a74798251213e58423cbc4a77185ffd74e6716 SHA512 6336d6f938330eee0b51f04665776269d974086ba56a3c8f4b7f53e7e17b637d899e9b329aeba3dcd690673a1a95a8cf03ae8417ebb9f356294314790915886a | ||
DIST awl-0.59.tar.gz 601449 BLAKE2B 606c52bdad06e6fa130fd20f7da25bc75c7357c81c1d34d88bb62c43b56857eb95492581b8845ff97416d94d64135ccaa5bcba0b3989a115156ade05bc1b26b8 SHA512 d3e82e7f3269c1c02c801628498768ec94a8d215b719369e8ee997d67c86c5e4e780571852a077511ffffbe91ade1d05bfc60ee03624fbaada1ce23f7335d3e3 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit vcs-snapshot | ||
|
||
DESCRIPTION="Andrew McMillan's Web Libraries" | ||
HOMEPAGE="https://gitlab.com/davical-project/awl" | ||
SRC_URI="${HOMEPAGE}/repository/archive.tar.gz?ref=r${PV} -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
|
||
DEPEND="test? ( dev-php/phpunit )" | ||
RDEPEND="dev-lang/php:*[pdo,postgres,xml]" | ||
|
||
src_compile() { | ||
: | ||
} | ||
|
||
src_test() { | ||
phpunit tests/ || die "test suite failed" | ||
} | ||
|
||
src_install() { | ||
dodoc debian/changelog | ||
insinto /usr/share/php/${PN} | ||
doins -r dba inc | ||
} |