Skip to content

Commit

Permalink
app-crypt/sbctl: add 0.10
Browse files Browse the repository at this point in the history
Signed-off-by: John Helmert III <[email protected]>
  • Loading branch information
ajakk committed Dec 31, 2022
1 parent a40e388 commit e31f591
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
3 changes: 3 additions & 0 deletions app-crypt/sbctl/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,6 @@
DIST sbctl-0.10-deps.tar.xz 21535928 BLAKE2B 8c63574ee8dafe998b28078553b30485aa34f75377602c83b4b04d3a65e6ba2ca162b8c3abe2a8dbf4d860258ae4178a6dad4b2835e3c2d79b4295a9539638b5 SHA512 4f811ed7fc78267e5b7dceb79b28e951e50c7affaf1acbbe1c75b1df8702511cdcf0ab3145c474644fc976a64e5beb147b2cf54ef6773d538d20876365a3e879
DIST sbctl-0.10.tar.gz 1627117 BLAKE2B e123d53094481249d43a3b98140a4fb28281f28d192d9834af65bdc077a60b51f53d6fb941eb54f63a5fc45aafe9d5b9a8858c2eb55636c4a1ca1cf3392e0f31 SHA512 73a12a78b0ae9e020f8ec168840dcb436c0ff54bbe3906643be65119ce925ba95f8d4558bd6868dbd6d2c1dcd6b16a8f8571fb465d36ef0d98229040db81ffdb
DIST sbctl-0.10.tar.gz.sig 566 BLAKE2B 8ecac994cb4705a4728bb0a1424ece06f394da87cf518395b3590949c5e9925965c57ec03c3b26e9f97073b2abc0348f7d822bdc351d5b230a87f422e7f836e4 SHA512 34910726155fce49c6c507b0d43fb01d1fc1782bd4cccaaed1fa286f63cd09af0a25f3dc295312770ff9afc931a19d9dbc71c02f0e92ae3fcce64205bcaeb9da
DIST sbctl-0.9-deps.tar.xz 21517024 BLAKE2B 6a90caf5bae7561d63d65777f8293012f946a1688dc86e2a9932ec1eb6cd3b89cd2293c202daa01ab8dc91952fcb7c47974a72d1750965d9d0636441d1405782 SHA512 6ec614082a15b2817f551d7b25353f1014bec7a86b730617168ba719695836571cbeff66b9ee57ebef37fcbfff4565117fc44ad1580b790a9cb031f861e71937
DIST sbctl-0.9.tar.gz 108318 BLAKE2B 8d50562e471416562e5cec07e155ea16cb919cff062435c3450e09c1d411b3a356f42a062aae74c5b826afe6f7853a68eb213b479797ca85bbd847d95d386f03 SHA512 5b1d02dce29ca2adc96048191ebdd07003d4ada28fb829fb829db27645710696502efe1c4b94166df7ddeceaa283cc713e7d9195c11291d426a69aa3cce5cf22
DIST sbctl-0.9.tar.gz.sig 566 BLAKE2B 1932291376bd993626cfeaa82a7a58ea8998eefbf8cf952a66ba9133d22f4da414a0cbe1e50382308d710fe7af0277582cb8c3d77cd043cb4d22c6e832da8c28 SHA512 39f7848796c92babe9ffd3928c71adee4987ab97ae8606baecaf2c7def7a5147624027450c6bfafc66e30c18d609354d06e5c30aeb362fabd8d7efcaed7e151d
33 changes: 33 additions & 0 deletions app-crypt/sbctl/sbctl-0.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit go-module verify-sig

DESCRIPTION="Secure Boot key manager"
HOMEPAGE="https://github.com/Foxboron/sbctl"
SRC_URI="https://github.com/Foxboron/${PN}/releases/download/${PV}/${P}.tar.gz
https://dev.gentoo.org/~ajak/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz
verify-sig? ( https://github.com/Foxboron/${PN}/releases/download/${PV}/${P}.tar.gz.sig )"

LICENSE="Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS="~amd64"

BDEPEND="app-text/asciidoc
verify-sig? ( sec-keys/openpgp-keys-foxboron )"

VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/foxboron.asc"

src_unpack() {
if use verify-sig; then
verify-sig_verify_detached "${DISTDIR}"/${P}.tar.gz{,.sig}
fi

default
}

src_install() {
emake PREFIX="${ED}/usr" install
}

0 comments on commit e31f591

Please sign in to comment.