Skip to content

Commit

Permalink
dev-libs/grantlee: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
kensington committed Apr 19, 2016
1 parent 2864d7a commit e34304a
Show file tree
Hide file tree
Showing 3 changed files with 99 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/grantlee/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST grantlee-0.4.0.tar.gz 1171445 SHA256 13a2d8121392404bb3be4ed470b211bc098cd98da795ef7bf41517d2fb640d3f SHA512 6ff539eb7aaf366487214b02131d67b9967713c42d20314ff56129e9543516fdf2d129b9c3015f0959c89c6f0ee9ad085af91fed4293bd0613d8e888bc850ca7 WHIRLPOOL ee639a72c6f785559b427a2f13483c256e19dbeb270ff34118a81547ea1f31a69aeaed7c58a2d89952b79d58e3acc88ef44f06cac32739747c7920ef66d621b0
DIST grantlee-5.0.0.tar.gz 1166498 SHA256 eaf22ba92e53b8eb5dd8bca045fe81b734d3445445ed9e0c1af2a0a7c375b161 SHA512 29b73fe4ee1b6e814ca91e4a3732208bada9b64bc8ace506bd8e888927b3fcd1a539e4ec03488901815692bd47424d8176fb2d6766461011e40fb33b221f6be4 WHIRLPOOL 418cb19061990a39c24d6be42c86f7f63a11d4451434dc2616072a4498268a1bc1de0d5de9163d2980420c1cc955e2f700a4722e19ebbeded5f0aa6a7393eb48
DIST grantlee-5.1.0.tar.gz 1175380 SHA256 ea2e402466c74bb533eee2c7252209ec61cd93a5d236fecd625b4a0eb13a1478 SHA512 2b806a0770b9c6d02f207d5b4939ae8cae325de4fa01901320ffef5c8442ef0f1c10dd799966d0bf0d223e6541f93db8568aaf922ea1b334bcb2f85f6373a936 WHIRLPOOL bbe96918cc28e5ab0112f4d5b6bca33825110997d3b91f009f699620168bc7310fe72e3b04fc5dcb93681196d6f2a02df29163b0dfcb5ab8816cba2755afe3c5
39 changes: 39 additions & 0 deletions dev-libs/grantlee/files/grantlee-5.1.0-slot.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
Install headers to a custom location to permit slotting with Qt4 version.

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1324566..f98d5da 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,7 +100,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define suffix of library directory name (eg. '6
set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
set( PLUGIN_INSTALL_DIR ${LIB_INSTALL_DIR}/grantlee/${Grantlee5_MAJOR_MINOR_VERSION_STRING} )
set( BIN_INSTALL_DIR bin )
-set( INCLUDE_INSTALL_DIR include )
+set( INCLUDE_INSTALL_DIR include/grantlee5 )
set( DATA_INSTALL_DIR share/apps )

# set up RPATH/install_name_dir
diff --git a/templates/lib/CMakeLists.txt b/templates/lib/CMakeLists.txt
index dad2ef8..434d163 100644
--- a/templates/lib/CMakeLists.txt
+++ b/templates/lib/CMakeLists.txt
@@ -107,6 +107,7 @@ if (Qt5Script_FOUND)

target_sources(Grantlee_Templates PRIVATE ${scriptabletags_SRCS})
target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
+ target_include_directories(Grantlee_Templates INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>")
target_link_libraries(Grantlee_Templates
LINK_PRIVATE Qt5::Script
)
diff --git a/textdocument/lib/CMakeLists.txt b/textdocument/lib/CMakeLists.txt
index 557d262..d2dbaa1 100644
--- a/textdocument/lib/CMakeLists.txt
+++ b/textdocument/lib/CMakeLists.txt
@@ -42,6 +42,7 @@ if (CMAKE_GENERATOR MATCHES "Visual Studio")
)
endforeach()
endif()
+target_include_directories(Grantlee_TextDocument INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>")

target_link_libraries(Grantlee_TextDocument
LINK_PUBLIC Qt5::Gui
59 changes: 59 additions & 0 deletions dev-libs/grantlee/grantlee-5.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

CMAKE_MIN_VERSION="3.1"
VIRTUALX_REQUIRED="test"
inherit cmake-utils virtualx

DESCRIPTION="C++ string template engine based on the Django template system"
HOMEPAGE="https://github.com/steveire/grantlee"
SRC_URI="http://downloads.grantlee.org/${P}.tar.gz"

LICENSE="LGPL-2.1+"
SLOT="5"
KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
IUSE="debug doc test"

RDEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtscript:5
"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
test? ( dev-qt/qttest:5 )
"

DOCS=( AUTHORS CHANGELOG README.md )

PATCHES=(
"${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
"${FILESDIR}/${PN}-5.1.0-slot.patch"
)

src_configure() {
local mycmakeargs=(
-DBUILD_TESTS=$(usex test)
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile

use doc && cmake-utils_src_compile docs
}

src_test() {
virtx cmake-utils_src_test
}

src_install() {
use doc && HTML_DOCS=("${BUILD_DIR}/apidox/")

cmake-utils_src_install
}

0 comments on commit e34304a

Please sign in to comment.