forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-editors/kile: Add 2.9.91_p20180208 snapshot
Package-Manager: Portage-2.3.24, Repoman-2.3.6
- Loading branch information
Showing
2 changed files
with
74 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kile-2.9.91_p20171209.tar.gz 3624273 BLAKE2B d6e4798869b8f5be7a2a6b00b1b067957245373f560a7485334ce1f3f932670a0cb8ef0b551fde2eea1d54a6114e8405025dbd3daea587a2d30b74fe614d332e SHA512 b7e4a6e434057cf04e8712f543cdd74a40659843b1e2777d0a031b5a665e1de34e36ec9b3f5d9bd3bf9202f9dca8595fcee9a81ab4875bc4b6da3a2fb449b2c6 | ||
DIST kile-2.9.91_p20180208.tar.gz 3635083 BLAKE2B 0579dac072a97f152009a4462759f40bfcdff4d4b6d463affcba7d71cda023f8c43d2173511bd268be22f2cc4412f091ec7ab70793e16781f5cf2023b1303db0 SHA512 24bc9221524f2213b0651d96273f35871a5fdf5c65edc4a5d72cb6e2635b1d23e55549ba60172a94691b7793d0a57e116cd94010be28e61231b8ee59b3f369dd |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,73 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
COMMIT=be912e1b8644053d80e5e37d3ccd07448670fb10 | ||
KDE_HANDBOOK="forceoptional" | ||
inherit kde5 vcs-snapshot | ||
|
||
DESCRIPTION="Latex Editor and TeX shell based on KDE Frameworks" | ||
HOMEPAGE="https://kile.sourceforge.io/" | ||
SRC_URI="https://github.com/KDE/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="FDL-1.2 GPL-2" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+pdf +png" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep kdbusaddons) | ||
$(add_frameworks_dep kdoctools) | ||
$(add_frameworks_dep kguiaddons) | ||
$(add_frameworks_dep khtml) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kiconthemes) | ||
$(add_frameworks_dep kinit) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep kparts) | ||
$(add_frameworks_dep ktexteditor) | ||
$(add_frameworks_dep kwindowsystem) | ||
$(add_frameworks_dep kxmlgui) | ||
$(add_kdeapps_dep okular) | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtscript) | ||
$(add_qt_dep qttest) | ||
$(add_qt_dep qtwidgets) | ||
pdf? ( app-text/poppler[qt5] ) | ||
" | ||
RDEPEND="${DEPEND} | ||
!app-editors/kile:4 | ||
$(add_kdeapps_dep konsole) | ||
$(add_kdeapps_dep okular 'pdf?') | ||
virtual/latex-base | ||
virtual/tex-base | ||
pdf? ( | ||
>=app-text/texlive-core-2014 | ||
app-text/ghostscript-gpl | ||
) | ||
png? ( | ||
app-text/dvipng | ||
virtual/imagemagick-tools[png?] | ||
) | ||
" | ||
|
||
DOCS=( kile-remote-control.txt ) | ||
|
||
src_prepare() { | ||
kde5_src_prepare | ||
|
||
# I know upstream wants to help us but it doesn't work.. | ||
sed -e '/INSTALL( FILES AUTHORS/s/^/#DISABLED /' \ | ||
-i CMakeLists.txt || die | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use_find_package pdf Poppler) | ||
) | ||
|
||
kde5_src_configure | ||
} |