Skip to content

Commit

Permalink
sys-devel/autogen: version bump to 5.18.12
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Sep 1, 2016
1 parent 03134eb commit e397711
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-devel/autogen/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST autogen-5.18.10.tar.xz 1017960 SHA256 4e248e02c50404ea5c5fc29027d26600f895a9eae7ea5ef851be2c8587abc148 SHA512 cfb06566aebe2aa833f2a032c513aa1d57a803eee82f03d6f6fe3806a0f570d5dbf8331015d2afde89a3d4e4c967b6a367d3e2820addb3ff6a5ac6d481a058be WHIRLPOOL 2eae849d10083da05e0c42931b5f52a9e6ab0f548473a3812e089515ec5ed76dc94008466ab6f4e5bcf5c220898aa7ffba6ecdcbde7d8fbe0134daf45788994a
DIST autogen-5.18.12.tar.xz 1018412 SHA256 be3ba62e883185b6ee8475edae97d7197d701d6b9ad9c3d2df53697110c1bfd8 SHA512 46de5910e2786a9b0ec96989d3e11be3ed12e5600f01d6fa9291bfbfae42a66994aeca2949837b471827ae3285ec4caafb42bc19ca91146cd7ea7a355aaffd03 WHIRLPOOL 73be676646d29563214de40921d0750bebaf2418d22c2830d6c0bd4287493375b7fbc3f1576425f449d937e16235985f7e7120ed44e8d48486439e7fb317fa33
DIST autogen-5.18.4.tar.xz 1017936 SHA256 7fbaff0c25035aee5b96913de2c83d9a5cc973b8dc08d6b7489ecbcfd72eb84b SHA512 a02363484de5019bd90fb6f2cf52b1b9556d6cf310c62a68830d0b2408ea4870d3c262fe5d1c27e3586ed3af4a7487d7422ad117760ac2a01ef3cfcfc1f2bfb6 WHIRLPOOL 109cb5637558f8e16cbb9afcb629a9bbd3d5ceae6b897a00101fce99b1a39b06ecc497d9b43441e40b58981dd2402027e89ce6ae76da73b73db934c64bca2b63
44 changes: 44 additions & 0 deletions sys-devel/autogen/autogen-5.18.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"

inherit eutils toolchain-funcs

DESCRIPTION="Program and text file generation"
HOMEPAGE="https://www.gnu.org/software/autogen/"
SRC_URI="mirror://gnu/${PN}/rel${PV}/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="libopts static-libs"

# This should be guile-1.8+, but upstream has a bug with older versions:
# https://savannah.gnu.org/support/index.php?109051
RDEPEND=">=dev-scheme/guile-2.0:=
dev-libs/libxml2"
DEPEND="${RDEPEND}"

src_prepare() {
# https://savannah.gnu.org/support/index.php?109050
sed -i \
-e "/--cflags-only-I/s:pkg-config:$(tc-getPKG_CONFIG):" \
configure || die
}

src_configure() {
# suppress possibly incorrect -R flag
export ag_cv_test_ldflags=

econf $(use_enable static-libs static)
}

src_install() {
default
prune_libtool_files

if ! use libopts ; then
rm "${ED}"/usr/share/autogen/libopts-*.tar.gz || die
fi
}

0 comments on commit e397711

Please sign in to comment.