forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/enable: Add support for gcc-5
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=561836 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <[email protected]>
- Loading branch information
Showing
3 changed files
with
27 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
From 55a74ccfc33764499497022dd3649be4bb1091ed Mon Sep 17 00:00:00 2001 | ||
From: Nathan Ringo <[email protected]> | ||
Date: Wed, 10 Jun 2015 22:06:57 -0500 | ||
Subject: [PATCH] Fixes #200 | ||
|
||
--- | ||
kiva/agg/setup.py | 2 +- | ||
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
diff --git a/kiva/agg/setup.py b/kiva/agg/setup.py | ||
index 5b4d458..c6e290a 100644 | ||
--- a/kiva/agg/setup.py | ||
+++ b/kiva/agg/setup.py | ||
@@ -170,7 +170,7 @@ def get_ft2_sources((lib_name, build_info), build_dir): | ||
f = os.popen("g++ --version") | ||
line0 = f.readline() | ||
f.close() | ||
- m = re.match(r'.+?\s(3|4)\.\d+', line0) | ||
+ m = re.match(r'.+?\s([3-5])\.\d+', line0) | ||
if int(m.group(1)) < 4: | ||
use_32bit_workaround = True | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters