Skip to content

Commit

Permalink
dev-python/enable: Add support for gcc-5
Browse files Browse the repository at this point in the history
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=561836

Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Oct 10, 2015
1 parent bce23af commit e3a0d23
Show file tree
Hide file tree
Showing 3 changed files with 27 additions and 2 deletions.
5 changes: 4 additions & 1 deletion dev-python/enable/enable-4.5.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -41,7 +41,10 @@ DEPEND="${RDEPEND}

DISTUTILS_IN_SOURCE_BUILD=1

PATCHES=( "${FILESDIR}"/${PN}-4.4.1-swig.patch )
PATCHES=(
"${FILESDIR}"/${PN}-4.4.1-swig.patch
"${FILESDIR}"/${P}-gcc-5.patch
)

python_prepare_all() {
append-cflags -fno-strict-aliasing
Expand Down
22 changes: 22 additions & 0 deletions dev-python/enable/files/enable-4.5.1-gcc-5.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
From 55a74ccfc33764499497022dd3649be4bb1091ed Mon Sep 17 00:00:00 2001
From: Nathan Ringo <[email protected]>
Date: Wed, 10 Jun 2015 22:06:57 -0500
Subject: [PATCH] Fixes #200

---
kiva/agg/setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/kiva/agg/setup.py b/kiva/agg/setup.py
index 5b4d458..c6e290a 100644
--- a/kiva/agg/setup.py
+++ b/kiva/agg/setup.py
@@ -170,7 +170,7 @@ def get_ft2_sources((lib_name, build_info), build_dir):
f = os.popen("g++ --version")
line0 = f.readline()
f.close()
- m = re.match(r'.+?\s(3|4)\.\d+', line0)
+ m = re.match(r'.+?\s([3-5])\.\d+', line0)
if int(m.group(1)) < 4:
use_32bit_workaround = True

2 changes: 1 addition & 1 deletion dev-python/enable/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
<?xml version='1.0' encoding='UTF-8'?>
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>python</herd>
Expand Down

0 comments on commit e3a0d23

Please sign in to comment.