Skip to content

Commit

Permalink
dev-ada/libadalang-tools: install libraries, too
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Dec 28, 2021
1 parent eb51ca1 commit e3c3b54
Show file tree
Hide file tree
Showing 3 changed files with 71 additions and 35 deletions.
67 changes: 67 additions & 0 deletions dev-ada/libadalang-tools/libadalang-tools-22.0.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

ADA_COMPAT=( gnat_2021 )
inherit ada multiprocessing

DESCRIPTION="Libadalang-based tools: gnatpp, gnatmetric and gnatstub"
HOMEPAGE="https://www.adacore.com/community"
SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
-> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+shared static-libs static-pic"

RESTRICT="test"

REQUIRED_USE="|| ( shared static-libs static-pic )
${ADA_REQUIRED_USE}"

RDEPEND="${ADA_DEPS}"
DEPEND="${RDEPEND}
dev-ada/libadalang:=[${ADA_USEDEP},static-libs?,static-pic?]"
BDEPEND="dev-ada/gprbuild[${ADA_USEDEP}]"

src_compile() {
build () {
gprbuild -v -k -XLIBRARY_TYPE=$1 -XBUILD_MODE=prod \
-P src/lal_tools.gpr -p -j$(makeopts_jobs) || die
gprbuild -v -k -XLIBRARY_TYPE=$1 -XXMLADA_BUILD=$1 \
-XBUILD_MODE=prod -XLALTOOLS_SET=all \
-P src/build.gpr -p -j$(makeopts_jobs) || die
}
if use shared; then
build relocatable
fi
if use static-libs; then
build static
fi
if use static-pic; then
build static-pic
fi
}

src_install() {
build () {
gprinstall -XLIBRARY_TYPE=$1 -XBUILD_MODE=prod \
--prefix="${D}"/usr --sources-subdir=include/lal_tools \
--build-name=$1 --build-var=LIBRARY_TYPE \
--build-var=LAL_TOOLS_BUILD \
-P src/lal_tools.gpr -p -f || die
}
if use shared; then
build relocatable
fi
if use static-libs; then
build static
fi
if use static-pic; then
build static-pic
fi
dobin bin/gnat{metric,pp,stub,test}
einstalldocs
}
35 changes: 0 additions & 35 deletions dev-ada/libadalang-tools/libadalang-tools-22.0.0.ebuild

This file was deleted.

4 changes: 4 additions & 0 deletions dev-ada/libadalang-tools/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -4,4 +4,8 @@
<maintainer type="project">
<email>[email protected]</email>
</maintainer>
<use>
<flag name="shared">Build shared library</flag>
<flag name="static-pic">Build static library with pic code</flag>
</use>
</pkgmetadata>

0 comments on commit e3c3b54

Please sign in to comment.