Skip to content

Commit

Permalink
x11-wm/xpra: Version bump. Set enable USE=lz4 by default (bug 609696,…
Browse files Browse the repository at this point in the history
… thanks Joe Stroller).

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
xmw committed Feb 20, 2017
1 parent c2e4391 commit e3cc4b9
Show file tree
Hide file tree
Showing 2 changed files with 146 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-wm/xpra/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST xpra-0.14.27.tar.xz 1123504 SHA256 9d51d6e656a9afc6559ec4b671a706ba134257c8
DIST xpra-0.14.36.tar.xz 1128276 SHA256 f929a9d05e2bc95cd7316efb839b8b1bcb88917ea513aa0c17adac4674702142 SHA512 bec07df063e72c42d2d2b4fff74ec01a6db8d97dae8c8f38ef0c994988ebcb8ee38363028eb7b64b562a540574f084e00a84f1c6e9e03bdbc47bfcd4d38a29aa WHIRLPOOL 650aa8d0c11114141c3ae44ccf8216a06812986fdf923334c025126c4341e686cdf65a00789d1b24895bc056b47b113c2c9474b60ed2e041a0b5b6619f6f7cda
DIST xpra-1.0.1.tar.xz 1887552 SHA256 415eea94dc7efabb1fd2e4eaa8a7665fefe65ed91be1cf31605394fb6d48ec17 SHA512 00b512c4a468043846f2f867fdf02d589069634302fda0a3da2df54cd3b49f592902c951edd0f367e32b372ee542f66330c4c254156337e1da0b36841199dcd3 WHIRLPOOL c789d153bbd4a0a78b3a691d406d9a0646faef08ae10a400e5c66928b2d11965da4e8605502633f65572e4fdb0370150c31103b13ac59d087a73b0aeddacda26
DIST xpra-1.0.2.tar.xz 1888452 SHA256 e32d2550c13d175681643696664790c9c59eda1e0ce1cea779ef7b0785f8bd2c SHA512 417d59f16422d42cf3f337b0710e48a55764cdfc56364388e7132581f2d470e533aad5eff2ee50f37f87416731ca6e6590ecb09cd6d747f873824943a845d4a4 WHIRLPOOL ed2d0b34cd5dc3635c56a46d5269e88ae674d69cb185b4e15a2e3c52bc3751cb3bd18cbb3e122f5db8d2b42b85ada7c865c36a38769b8d113a2338890dc86402
DIST xpra-1.0.3.tar.xz 1888908 SHA256 f83c5946f67fe26eee8b44fba0fa30bca9fbc7aa58ee66b903b7385c2d332166 SHA512 3b6371d478147a5d932df1c8428e9132831fcbf17e51f48fb384c30548efee9758c94a6781c255b5fe211c5040993f30b054aa33f3fced85484fcc9d2ca009a1 WHIRLPOOL 989db8ac2caa3a5a0e1294754cabe6bc8cadb087a6ffa24de3039c674126886a41ecab930c46700dccdf3adc738572e04652123c9523512c050ffdff3d295b02
145 changes: 145 additions & 0 deletions x11-wm/xpra/xpra-1.0.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,145 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

# PyCObject_Check and PyCObject_AsVoidPtr vanished with python 3.3, and setup.py not python3.2 compat
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 eutils flag-o-matic user

DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
HOMEPAGE="http://xpra.org/ http://xpra.org/src/"
SRC_URI="http://xpra.org/src/${P}.tar.xz"

LICENSE="GPL-2 BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="+client +clipboard csc cups dec_av2 enc_ffmpeg libav +lz4 lzo opengl pulseaudio server sound vpx webcam webp x264 x265"

REQUIRED_USE="${PYTHON_REQUIRED_USE}
clipboard? ( || ( server client ) )
opengl? ( client )
|| ( client server )
client? ( x264? ( dec_av2 ) x265? ( dec_av2 ) )"

# x264/old-libav.path situation see bug 459218
COMMON_DEPEND=""${PYTHON_DEPS}"
dev-python/pygobject:2[${PYTHON_USEDEP}]
dev-python/pygtk:2[${PYTHON_USEDEP}]
x11-libs/gtk+:2
x11-libs/libX11
x11-libs/libXcomposite
x11-libs/libXdamage
x11-libs/libXfixes
x11-libs/libXrandr
x11-libs/libXtst
csc? (
!libav? ( >=media-video/ffmpeg-1.2.2:0= )
libav? ( media-video/libav:0= )
)
dec_av2? (
!libav? ( >=media-video/ffmpeg-2:0= )
libav? ( media-video/libav:0= )
)
enc_ffmpeg? (
!libav? ( >=media-video/ffmpeg-3.2.2:0= )
libav? ( media-video/libav:0= )
)
opengl? ( dev-python/pygtkglext )
pulseaudio? ( media-sound/pulseaudio )
sound? ( media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
dev-python/gst-python:1.0 )
vpx? ( media-libs/libvpx virtual/ffmpeg )
webp? ( media-libs/libwebp )
x264? ( media-libs/x264
!libav? ( >=media-video/ffmpeg-1.0.4:0= )
libav? ( media-video/libav:0= )
)
x265? ( media-libs/x265
!libav? ( >=media-video/ffmpeg-2:0= )
libav? ( media-video/libav:0= )
)"

RDEPEND="${COMMON_DEPEND}
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/rencode[${PYTHON_USEDEP}]
virtual/ssh
x11-apps/xmodmap
cups? ( dev-python/pycups[${PYTHON_USEDEP}] )
lz4? ( dev-python/lz4[${PYTHON_USEDEP}] )
lzo? ( >=dev-python/python-lzo-0.7.0[${PYTHON_USEDEP}] )
opengl? (
client? ( dev-python/pyopengl_accelerate[${PYTHON_USEDEP}] )
)
server? ( x11-base/xorg-server[-minimal,xvfb]
x11-drivers/xf86-input-void
x11-drivers/xf86-video-dummy
)
webcam? ( media-libs/opencv[python]
dev-python/pyinotify[${PYTHON_USEDEP}] )"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
>=dev-python/cython-0.16[${PYTHON_USEDEP}]"

pkg_postinst() {
enewgroup ${PN}
}

python_prepare_all() {
rm -rf rencode || die

epatch \
"${FILESDIR}"/${PN}-0.13.1-ignore-gentoo-no-compile.patch \
"${FILESDIR}"/${PN}-0.17.4-deprecated-avcodec.patch

if use libav ; then
if ! has_version ">=media-video/libav-9" ; then
epatch patches/old-libav.patch
fi
fi

if ! use pulseaudio ; then #bug 608126
sed -e '/pulseaudio/s:bstr(not OSX and not WIN32):bstr(False):' \
-i setup.py || die
fi

distutils-r1_python_prepare_all
}

python_configure_all() {
mydistutilsargs=(
$(use_with client)
$(use_with clipboard)
$(use_with csc csc_swscale)
$(use_with cups printing)
$(use_with dec_av2 dec_avcodec2)
$(use_with enc_ffmpeg)
$(use_with opengl)
$(use_with server shadow)
$(use_with server)
$(use_with sound)
$(use_with vpx)
$(use_with webp)
$(use_with x264 enc_x264)
$(use_with x265 enc_x265)
$(use_with webcam)
--with-Xdummy
--with-gtk2
--without-gtk3
--with-strict
--with-warn
--with-x11
--without-PIC
--without-debug )

# see https://www.xpra.org/trac/ticket/1080
# and http://trac.cython.org/ticket/395
append-cflags -fno-strict-aliasing

export XPRA_SOCKET_DIRS="${EROOT}run/xpra"
}

0 comments on commit e3cc4b9

Please sign in to comment.