Skip to content

Commit

Permalink
app-text/bibletime: backport patch from upstream solving build with Q…
Browse files Browse the repository at this point in the history
…t 5.5

Package-Manager: portage-2.2.26
  • Loading branch information
kensington committed Dec 27, 2015
1 parent 1054b33 commit e3f1a50
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/bibletime/bibletime-2.10.1-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -55,6 +55,7 @@ src_prepare() {
sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt:" \
-i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
epatch "${FILESDIR}/${PN}-2.10.1-qt5-printsupport.patch"
epatch "${FILESDIR}/${PN}-2.10.1-qt55.patch"
}

src_configure() {
Expand Down
32 changes: 32 additions & 0 deletions app-text/bibletime/files/bibletime-2.10.1-qt55.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
From: Gary Holmlund <[email protected]>
Date: Fri, 3 Jul 2015 21:32:26 -0700
Subject: [PATCH] backend: Fix Qt 5.5 compile error with Q_ASSERT.

---
src/backend/drivers/cswordmoduleinfo.cpp | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/src/backend/drivers/cswordmoduleinfo.cpp b/src/backend/drivers/cswordmoduleinfo.cpp
index f86f9ac..ae7444f 100644
--- a/src/backend/drivers/cswordmoduleinfo.cpp
+++ b/src/backend/drivers/cswordmoduleinfo.cpp
@@ -54,7 +54,7 @@ const unsigned long BT_MAX_LUCENE_FIELD_LENGTH = 1024 * 1024;
CSwordModuleInfo::CSwordModuleInfo(sword::SWModule * module,
CSwordBackend & backend,
ModuleType type)
- : m_module((Q_ASSERT(module), module)),
+ : m_module(module),
m_backend(backend),
m_type(type),
m_cancelIndexing(false),
@@ -63,6 +63,7 @@ CSwordModuleInfo::CSwordModuleInfo(sword::SWModule * module,
{
initCachedCategory();
initCachedLanguage();
+ Q_ASSERT(module);

m_hidden = btConfig().value<QStringList>("state/hiddenModules",
QStringList()).contains(m_cachedName);
--
2.4.10

0 comments on commit e3f1a50

Please sign in to comment.