Skip to content

Commit

Permalink
dev-ruby/date: add 3.3.3
Browse files Browse the repository at this point in the history
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Dec 25, 2022
1 parent 79b7f0c commit e3faa27
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/date/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST date-3.2.2.tar.gz 108973 BLAKE2B aedb4d5d43b1d7ac277bc6fd36651f36828be7a04f4eb75c45ea02bc56b3a403af9e8a26b23a9839c904ae455e6a02476fe83115d8c816f06168db6e0a788347 SHA512 5a640b550c9ea0c1fa24aa5d114ae9108fd568c8c38b20434168a92c886d66487065e0c6aedc7e55cbe59cc3338fd262ca601267ed0b55377c382fe0502e9604
DIST date-3.3.0.tar.gz 108249 BLAKE2B 7d85337c1b39b09d15a73a47b5e09788a700a0e044fc74a4138be490d7212174e3cc03c40c7b4814bc69523399826832c48c07a38e0cfb6f28554f584cf81fe0 SHA512 1e20c5a29b0aabc3354b6c39e0dcc4cbeafc6b74afddd5b4446b7a7b608832f072c86b98267893267d0372ba7ab0bfd71862369cd8d35b162cba8bdd81563a57
DIST date-3.3.1.tar.gz 108337 BLAKE2B 90241a005755c330dab010aa2d1a0c6192b7de3e33f0b3fe8089385d2aed0a834ea96b71e276f2cf5bbddc187c915a5d93e38cfcddeaf267d803113895b9fd3f SHA512 8eb701542619320fc4400440b8c8a03626a389e0c94bf1e17f4bf952d616e5cbbce0f3714d824db255734386fb5b5522e220f619533f4c901746bb7d630e8275
DIST date-3.3.3.tar.gz 109793 BLAKE2B c7ee6337a520172b692a48c963a67d7fe7f6f56dd6ea5a957eda32d7c21fee7d02d0616f39c32abf61ae5f33f6507c508e98c568fd8f7baf300dfc5658945917 SHA512 a2224fa191fd688593af29b95e40f67e9fb9acea93b7de613d9c4b105343434a9ef30f32599cd6af243dd3e35a9bf1f60b722e6a0bc4393e26e83734196e8193
33 changes: 33 additions & 0 deletions dev-ruby/date/date-3.3.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
USE_RUBY="ruby27 ruby30 ruby31"

RUBY_FAKEGEM_BINWRAP=""
RUBY_FAKEGEM_EXTENSIONS=(ext/date/extconf.rb)
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_GEMSPEC="date.gemspec"
RUBY_FAKEGEM_RECIPE_DOC="none"

inherit ruby-fakegem

DESCRIPTION="A subclass of Object includes Comparable module for handling dates"
HOMEPAGE="https://github.com/ruby/date"
SRC_URI="https://github.com/ruby/date/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

all_ruby_prepare() {
sed -e 's/__dir__/"."/' \
-e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
-e 's/git ls-files -z/find * -print0/' \
-i ${RUBY_FAKEGEM_GEMSPEC} || die
}

each_ruby_test() {
${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
}

0 comments on commit e3faa27

Please sign in to comment.