Skip to content

Commit

Permalink
dev-java/freehep-graphicsbase: New FreeHEP component, needed by others
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0_rc1
  • Loading branch information
chewi committed May 25, 2016
1 parent 21ecc35 commit e41c023
Show file tree
Hide file tree
Showing 3 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/freehep-graphicsbase/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST freehep-vectorgraphics-2.4.tar.gz 4118379 SHA256 2c7e1bbb3c056e9de83e5f7d9e0b2aeb3f46734000cdd0f18423eb43216305dd SHA512 b5cf083cc6951e7c4b438d5e648f61ca20b23e02163a8cfc4669beaaec2fa9e33338b0ba6875bfe4a3864ac48f9774acfedc2a3b2f59a7488ef99a4817e39382 WHIRLPOOL 62d61e05935348cf8b5d81033408729b02377f8a91760d08ab98a8e1451ea4d44e992a98dfb951978272ca842dbfa0d2885430cd16428dcf4da005aa092fbe76
49 changes: 49 additions & 0 deletions dev-java/freehep-graphicsbase/freehep-graphicsbase-2.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

MY_PN="freehep-vectorgraphics"
MY_P="${MY_PN}-${PV}"
JAVA_PKG_IUSE="doc source"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="High Energy Physics Java library - FreeHEP Graphics Base Library"
HOMEPAGE="http://java.freehep.org/"
SRC_URI="https://github.com/freehep/${MY_PN}/archive/${MY_P}.tar.gz"
LICENSE="Apache-2.0 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

CDEPEND="dev-java/freehep-io:0
dev-java/junit:4"

DEPEND="${CDEPEND}
>=virtual/jdk-1.7"

RDEPEND="${CDEPEND}
>=virtual/jre-1.7"

S="${WORKDIR}/${MY_PN}-${MY_P}/${PN}"
JAVA_SRC_DIR="src/main/java"
JAVA_GENTOO_CLASSPATH="freehep-io,junit-4"

src_compile() {
java-pkg-simple_src_compile
java-pkg_addres ${PN}.jar src/main/resources
}

src_test() {
local DIR=src/test/java
local CP="${DIR}:${PN}.jar:$(java-pkg_getjars ${JAVA_GENTOO_CLASSPATH})"
local TESTS=$(find ${DIR} -name "*Test.java" ! -name "ExportFileTypeTest.java")
TESTS="${TESTS//src\/test\/java\/}"
TESTS="${TESTS//.java}"
TESTS="${TESTS//\//.}"

ejavac -cp "${CP}" -d ${DIR} $(find ${DIR} -name "*.java")
ejunit4 -classpath "${CP}" ${TESTS}
}
11 changes: 11 additions & 0 deletions dev-java/freehep-graphicsbase/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Java</name>
</maintainer>
<upstream>
<remote-id type="github">freehep/freehep-vectorgraphics</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit e41c023

Please sign in to comment.