Skip to content

Commit

Permalink
dev-libs/newt: add 0.52.22
Browse files Browse the repository at this point in the history
Signed-off-by: Ben Kohler <[email protected]>
  • Loading branch information
benkohler committed Nov 22, 2022
1 parent 35aa300 commit e41d8af
Show file tree
Hide file tree
Showing 3 changed files with 117 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/newt/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST newt-0.52.21_p20210816.tar.gz 128555 BLAKE2B 97c791d7301b657bec68045f2cd9bbe16eef0b099a6304e2336414837b36492bd794be04d0bbcd9eadc6fcd000ba2563a5ab90be5d61249390a6ea5435091f97 SHA512 06c1d5634d88a6126de5eddd1c4d436639a4d739b100f391638b0429a3941eabcaa0ff7398f498d735ec0af5e88deb14178110ab11bf5301ef661f7953692bc4
DIST newt-0.52.22.tar.gz 128543 BLAKE2B 103ebe43ccd186068ffd468e56698e9f6f90ab5d687a14a27d454cfd68feb4ccd11710b6c472c07905a4aeb915efefd4f3b90c3c7822db7cdd5923c53996b7ae SHA512 2881340f97afccb8be02b2915a6f1de26de6c1e7c7b97776b8d2c87386e3f3611697a47b7e9b1a043f334d72b6d2bdcb7fd3ff128a7d994fcb437f456873016c
13 changes: 13 additions & 0 deletions dev-libs/newt/files/newt-0.52.22-gold.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
diff -ur a/configure.ac b/configure.ac
--- a/configure.ac 2022-11-21 07:58:11.000000000 -0600
+++ b/configure.ac 2022-11-21 20:56:42.211913050 -0600
@@ -24,7 +24,8 @@
AC_MSG_CHECKING([for GNU ld])
LD=$($CC -print-prog-name=ld 2>&5)

-if test $($LD -v 2>&1 | $ac_cv_path_GREP -c "GNU ld") = 0; then
+if test $($LD -v 2>&1 | $ac_cv_path_GREP -c "GNU ld") = 0 -a \
+ test $($LD -v 2>&1 | $ac_cv_path_GREP -c "GNU gold") = 0; then
# Not
GNU_LD=""
AC_MSG_RESULT([no])
103 changes: 103 additions & 0 deletions dev-libs/newt/newt-0.52.22.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,103 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..11} )

inherit autotools python-r1 toolchain-funcs

MY_PV="r$(ver_rs 1- -)"

DESCRIPTION="Redhat's Newt windowing toolkit development files"
HOMEPAGE="https://pagure.io/newt"
SRC_URI="https://github.com/mlichvar/newt/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
IUSE="gpm nls tcl"
RESTRICT="test"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="
${PYTHON_DEPS}
>=dev-libs/popt-1.6
=sys-libs/slang-2*
gpm? ( sys-libs/gpm )
tcl? ( >=dev-lang/tcl-8.5:0 )
"
DEPEND="${RDEPEND}"
BDEPEND="sys-devel/gettext"

PATCHES=(
"${FILESDIR}"/${PN}-0.52.22-gold.patch
"${FILESDIR}"/${PN}-0.52.14-tcl.patch
"${FILESDIR}"/${PN}-0.52.21-python-sitedir.patch
)

S=${WORKDIR}/${PN}-${MY_PV}

src_prepare() {
sed -i Makefile.in \
-e 's|$(SHCFLAGS) -o|$(LDFLAGS) &|g' \
-e 's|-g -o|$(CFLAGS) $(LDFLAGS) -o|g' \
-e 's|-shared -o|$(CFLAGS) $(LDFLAGS) &|g' \
-e 's|instroot|DESTDIR|g' \
-e 's| make | $(MAKE) |g' \
-e "s| ar | $(tc-getAR) |g" \
|| die "sed Makefile.in"

if [[ -n ${LINGUAS} ]]; then
local lang langs
for lang in ${LINGUAS}; do
test -r po/${lang}.po && langs="${langs} ${lang}.po"
done
sed -i po/Makefile \
-e "/^CATALOGS = /cCATALOGS = ${langs}" \
|| die "sed po/Makefile"
fi

default
eautoreconf

# can't build out-of-source
python_copy_sources
}

src_configure() {
configuring() {
econf \
PYTHONVERS="${PYTHON}" \
$(use_with gpm gpm-support) \
$(use_with tcl) \
$(use_enable nls)
}
python_foreach_impl run_in_build_dir configuring
}

src_compile() {
building() {
emake PYTHONVERS="${EPYTHON}"
}
python_foreach_impl run_in_build_dir building
}

src_install() {
installit() {
emake \
DESTDIR="${D}" \
PYTHON_SITEDIR="$(python_get_sitedir)" \
PYTHONVERS="${EPYTHON}" \
install
python_optimize
}
python_foreach_impl run_in_build_dir installit
dodoc peanuts.py popcorn.py tutorial.sgml
doman whiptail.1
einstalldocs

# don't want static archives
rm "${ED}"/usr/$(get_libdir)/libnewt.a || die
}

0 comments on commit e41d8af

Please sign in to comment.