Skip to content

Commit

Permalink
dev-ml/camlimages: bump to 4.2.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
aballier committed May 6, 2016
1 parent a5b7325 commit e4332ff
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/camlimages/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST camlimages-4.0.1.tar.bz2 2010729 SHA256 b6a5e79abcfba1316a516f2e0290e6f06c9
DIST camlimages-4.1.1.tar.bz2 1098450 SHA256 22c4485f69ddda6fa94fcb62c1f996756c93ceb59d6d61962d41df59fa27e346 SHA512 79dc5680ef632968d39513cac161f0e5daf4faecec12f100d56755051d257b1c0e4e45990d4215c4b95596b5d94cebc93b6d828953450b15a4e48993013637b2 WHIRLPOOL f18c3b7046c39c7ae05c91845cd4bd7f8cc52043180be6e21d9f19cfd055aba630cc7f9fc839d2caaba47946269008e952ee31e27aee5e0f184366ab2a183f7c
DIST camlimages-4.1.2.tar.bz2 1099399 SHA256 71de393656d60555ce3fb0ca7da13a6e0a74fdebad541a7790395e3b1d6cedde SHA512 8c41eef07418719643fc69d62f2d02b248731cb64efd81bc02cc61363da71ad11cf85eb9010674a10d17f9e90d169ca98e5c61d95ae835d0476cf9cfc492f453 WHIRLPOOL d6b3908b6d9c18462b69d7806113e423a5835812148e6e835329c3ab378a351c7f58423e63c942771e37bb30bdf4d61c089ab2d0212936150f0b1831b961d966
DIST camlimages-4.2.1.tar.bz2 1098703 SHA256 3d9b9d6a41f4b80e36574e8046acbe0514c1fcf2c5ffa11d375891485be1f266 SHA512 611a5f1eb383efed9b3ffd4801b28386f8317abe7bb25ff45a61a7e7ba911b6632852c8d3082b830d9e780fc70c03cb480c7a9f1440aa1259c60036813d07792 WHIRLPOOL eecf3a4ff1adfc458c2a48d5091ff4432fdd137e127a496cf288e13a071dbc0421045242a3fc43b8efe0d3041e8cc490d8e941290dd3f52e1888762eb69cd585
DIST camlimages-4.2.2.tar.bz2 789441 SHA256 eb96aa60afb139797836c2569ba1d4e3f2d0e4dbb025c117d7325468ce6c9633 SHA512 672e192255a9335c45d208b7589a344f712baa798dfc7bc7ccee7d3bda71e603bc06c7b012761f9c6372c683560c67ffa9d2af2742552884211ad4ffb541e3dd WHIRLPOOL dfe61d34da78b1d70feba1c2cf2717430ae4c99386d39fde3cfe14163665bd35a02947fcbc05f67c03de56b2fba1a13cd60a40031e1adbf6320ac239c1485c15
66 changes: 66 additions & 0 deletions dev-ml/camlimages/camlimages-4.2.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils vcs-snapshot findlib multilib

DESCRIPTION="An image manipulation library for ocaml"
HOMEPAGE="http://gallium.inria.fr/camlimages/"
SRC_URI="https://bitbucket.org/camlspotter/camlimages/get/${PV}.tar.bz2 -> ${P}.tar.bz2"

LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc exif gif gtk jpeg png postscript tiff truetype X xpm"

RDEPEND=">=dev-lang/ocaml-3.10.2:=[X?,ocamlopt]
exif? ( media-libs/libexif )
gif? ( media-libs/giflib )
gtk? ( dev-ml/lablgtk )
jpeg? ( virtual/jpeg )
tiff? ( media-libs/tiff )
png? ( >=media-libs/libpng-1.4:0 )
postscript? ( app-text/ghostscript-gpl )
truetype? ( >=media-libs/freetype-2 )
xpm? ( x11-libs/libXpm )
X? ( x11-apps/rgb )
sys-libs/zlib
"
DEPEND="${DEPEND}
doc? ( dev-python/sphinx[latex] )
dev-util/omake
virtual/pkgconfig
dev-ml/findlib"

camlimages_arg_want() {
echo "ARG_WANT_${2}=$(usex $1 1 0)"
}

src_compile() {
omake \
$(camlimages_arg_want exif EXIF ) \
$(camlimages_arg_want gif GIF ) \
$(camlimages_arg_want png PNG ) \
$(camlimages_arg_want jpeg JPEG ) \
$(camlimages_arg_want tiff TIFF ) \
$(camlimages_arg_want xpm XPM ) \
$(camlimages_arg_want postscript GS ) \
$(camlimages_arg_want gtk LABLGTK2) \
$(camlimages_arg_want X GRAPHICS) \
$(camlimages_arg_want truetype FREETYPE) \
PATH_GS=/bin/true \
--force-dotomake || die

if use doc ; then
sphinx-build doc/sphinx sphinxdoc || die
fi
}

src_install() {
findlib_src_preinst
omake --force-dotomake DESTDIR="${D}" install || die
dodoc README.md
use doc && dohtml -r sphinxdoc/*
}

0 comments on commit e4332ff

Please sign in to comment.