Skip to content

Commit

Permalink
dev-ruby/actionmailbox: add 6.1.7.4
Browse files Browse the repository at this point in the history
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Jun 28, 2023
1 parent 743395d commit e46bb01
Show file tree
Hide file tree
Showing 3 changed files with 126 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/actionmailbox/Manifest
Original file line number Diff line number Diff line change
@@ -1,6 +1,7 @@
DIST rails-6.0.6.1.tgz 18608328 BLAKE2B 10e6cb2d23acb75c95c25e2e6cc62de05c9c89f249c6cb9abffdd3a6ed83eb1dca996e6ef56a92cf77dddd3f8f9373ad947690015fb7966ddc599c995cea1121 SHA512 6873354fe2f8b9bf8bc12c7e6affda4300c158ee825f996eea6032a70f9532009d8f626d2736af22a452c8a3b331d1252ff19666e021150bfae2a8d575890c27
DIST rails-6.1.7.2.tgz 11037081 BLAKE2B 0004f4bc8b2370119cbe0f6a9133278ae78b1d274f040f08d18edd06696e6fcc609154a042c68b77e11893fbef83ec8eabd9f1e2c28920269189ee1352a0695a SHA512 f667904b0d3ffda3579e5046da3b36c242581bacf140966bf1dc59fc7ea91f34f4affc76b0d6cfad4b80f0332aeec5fc8ab35fb793fc935f1d1b4fe6d18ce1de
DIST rails-6.1.7.3.tgz 11038169 BLAKE2B 7e379b9ae3b63cb78638c1e0817ff40dc8aad79ba76b6d82310fbb4d6f5ef3dab4f252de9e49766143b828bfbce2ef7c9db3f108b5406708b61a83aeda47ea74 SHA512 fb84516a6cf370109bf45f2162161d23f375d7dc10249ed10200c74ec402129b07ac0e59bcde98a74eb499769a0cdd937af691edaabe44e061262d5510adc02e
DIST rails-6.1.7.4.tgz 11038583 BLAKE2B 737044b6f92f2555fd9374e0b0fef7e26e53e2ac2103f1e3d89124929416aeda1295adfa7493471472c6ff0fbb057dea0bd9c184bbb45ae572185b98c399177f SHA512 caa7e2a79f747befb5f6f17adec1cc43530dbb35741775b2ebdcf59476efecd277dad025073a4b519a35754367cca04290c24bb8d8ae4235fda696ead531a94f
DIST rails-7.0.4.3.tgz 11063764 BLAKE2B 389fd3a00bfff4ebda70cf5ec473942883048783b716ede1787a510d3b7b91f4e844dce4dde5ef643cb9611b1b3aa712f1ba5ebefb9e5a84e307a151b2e40bcf SHA512 2c817a0a58ae52f99686d8cd0de84f01e3d7ec05afc95d07910b3b5bf86d8162b06102893b2cbc14859b95a07eca6882a707956c87d437794697df7a18fa3c16
DIST rails-7.0.5.1.tgz 11077848 BLAKE2B 17dc2527b762d242c1cc141b5480c0917c8eafb53c55d3034d5af272e9be5760f6c3e16ce1a60041f11af4f99da23e79ff46e9f9fe88412932f2524bf057c478 SHA512 5053ed666cede0bfeb7a534f248538406a1bf5afe0d5ee9e285b4eeb3158566fdd665c7a20012833e6927e7dbb3d881361a5d7f8ce7e326f8e3faf5d571da3e7
DIST rails-7.0.5.tgz 11057290 BLAKE2B c9a2c34cc57f71a45023465796d18f769363713b3222dc67040e9d731055fe60856c4969a0fae305f99722e8f3a1aaee0f6cc0cc5e3e57949b756786f44560f9 SHA512 93f5d2f0e23ac318370ac15fdb4db935b9082232308fdc7bb99bca1b00e1b5127ddc805dd19512a2304921ff7b8a584c7b3d3ceb7cbd4cfd8dca31f518430448
68 changes: 68 additions & 0 deletions dev-ruby/actionmailbox/actionmailbox-6.1.7.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
USE_RUBY="ruby30 ruby31 ruby32"

RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"

RUBY_FAKEGEM_GEMSPEC="actionmailbox.gemspec"

RUBY_FAKEGEM_BINWRAP=""
RUBY_FAKEGEM_EXTRAINSTALL="app config db"

inherit ruby-fakegem

DESCRIPTION="Framework for designing email-service layers"
HOMEPAGE="https://github.com/rails/rails"
SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
IUSE=""

RUBY_S="rails-${PV}/${PN}"

PATCHES=(
"${FILESDIR}"/${P}-mail28.patch
)

ruby_add_rdepend "
~dev-ruby/actionpack-${PV}
~dev-ruby/activejob-${PV}
~dev-ruby/activerecord-${PV}
~dev-ruby/activestorage-${PV}
~dev-ruby/activesupport-${PV}
>=dev-ruby/mail-2.7.1:*
"

ruby_add_bdepend "test? (
dev-ruby/bundler
<dev-ruby/mail-2.8
<dev-ruby/minitest-5.16
dev-ruby/mocha
dev-ruby/rexml
dev-ruby/sqlite3
dev-ruby/webmock
dev-ruby/rails
)"

all_ruby_prepare() {
# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|webrick\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|rack-test\|capybara\|webpacker\|bootsnap\|dalli\|connection_pool\)/ s:^:#:" \
-e '/group :\(cable\|doc\|job\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
-i ../Gemfile || die
rm ../Gemfile.lock || die
sed -i -e '/byebug/ s:^:#:' test/test_helper.rb || die

# Avoid a test failing because the actionmailer part of the tarball
# is not patched for ruby32. Fixed in next upstream release.
rm -f test/unit/mailbox/bouncing_test.rb || die
}

each_ruby_prepare() {
sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
}
57 changes: 57 additions & 0 deletions dev-ruby/actionmailbox/files/actionmailbox-6.1.7.4-mail28.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
From f5463f314886016fb40199d1265cacddf64ea357 Mon Sep 17 00:00:00 2001
From: Jean Boussier <[email protected]>
Date: Mon, 5 Dec 2022 11:59:45 +0100
Subject: [PATCH] Merge pull request #46643 from ghiculescu/mail-28

Fix CI for Mail 2.8+
---
.../lib/action_mailbox/mail_ext/addresses.rb | 19 +++++++++++++++----
1 file changed, 15 insertions(+), 4 deletions(-)

diff --git a/actionmailbox/lib/action_mailbox/mail_ext/addresses.rb b/actionmailbox/lib/action_mailbox/mail_ext/addresses.rb
index 5eab1feb3d563..7da7ee2586a62 100644
--- a/lib/action_mailbox/mail_ext/addresses.rb
+++ b/lib/action_mailbox/mail_ext/addresses.rb
@@ -3,7 +3,7 @@
module Mail
class Message
def from_address
- header[:from]&.address_list&.addresses&.first
+ address_list(header[:from])&.addresses&.first
end

def recipients_addresses
@@ -11,19 +11,30 @@ def recipients_addresses
end

def to_addresses
- Array(header[:to]&.address_list&.addresses)
+ Array(address_list(header[:to])&.addresses)
end

def cc_addresses
- Array(header[:cc]&.address_list&.addresses)
+ Array(address_list(header[:cc])&.addresses)
end

def bcc_addresses
- Array(header[:bcc]&.address_list&.addresses)
+ Array(address_list(header[:bcc])&.addresses)
end

def x_original_to_addresses
Array(header[:x_original_to]).collect { |header| Mail::Address.new header.to_s }
end
+
+ private
+ def address_list(obj)
+ if obj&.respond_to?(:element)
+ # Mail 2.8+
+ obj.element
+ else
+ # Mail <= 2.7.x
+ obj&.address_list
+ end
+ end
end
end

0 comments on commit e46bb01

Please sign in to comment.