Skip to content

Commit

Permalink
app-backup/bup: initial import
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Nov 4, 2016
1 parent f21df67 commit e478f1f
Show file tree
Hide file tree
Showing 3 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-backup/bup/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST bup-0.28.1.tar.gz 377712 SHA256 fd962dbdade1b8ea257ac0e95d771ba11e6da4ef6f8ca6bee498a5b1bce8c817 SHA512 b27a94eeee86366f9f97081611d8e0443686ed8c4070d45729ad4efe1d48ee9f528d3257bfd5d37d6243927f5b63d6b613bf5ae2c39117012979ccd5ccecf9d2 WHIRLPOOL 5415df9bee662e0ffdcd81fa766c56a2d747df269d78dda0341bf59d607f4d2570bb1d9fdb055d4bc11992a707b8a36b1d9d7f11d0cfd6e504aa501e1cec7ba1
57 changes: 57 additions & 0 deletions app-backup/bup/bup-0.28.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 )

inherit python-single-r1

DESCRIPTION="A highly efficient backup system based on the git packfile format"
HOMEPAGE="https://bup.github.io/ https://github.com/bup/bup"
SRC_URI="https://github.com/bup/bup/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test web"

RDEPEND="${PYTHON_DEPS}
app-arch/par2cmdline
dev-python/fuse-python[${PYTHON_USEDEP}]
dev-python/pylibacl[${PYTHON_USEDEP}]
dev-python/pyxattr[${PYTHON_USEDEP}]
web? ( www-servers/tornado[${PYTHON_USEDEP}] )
sys-libs/readline:0
dev-vcs/git"
DEPEND="${RDEPEND}
test? (
dev-lang/perl
net-misc/rsync
)
app-text/pandoc
"

# unresolved sandbox issues
RESTRICT="test"

src_prepare() {
default

sed -e "/^CFLAGS :=/s/-O2 -Werror//" \
-i Makefile || die
}

src_configure() {
./configure || die
}

src_test() {
emake test
}

src_install() {
emake DESTDIR="${D}" PREFIX=/usr LIBDIR="/usr/$(get_libdir)/bup" DOCDIR="/usr/share/${PF}" install
python_fix_shebang "${ED}"
python_optimize "${ED}"
}
14 changes: 14 additions & 0 deletions app-backup/bup/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Tim Harder</name>
</maintainer>
<use>
<flag name="web">Support browsing backups via a web interface</flag>
</use>
<upstream>
<remote-id type="github">bup/bup</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit e478f1f

Please sign in to comment.