Skip to content

Commit

Permalink
app-text/groonga: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Brian Evans committed Jan 4, 2017
1 parent 5357a64 commit e48061f
Show file tree
Hide file tree
Showing 2 changed files with 93 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/groonga/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST groonga-4.0.7.tar.gz 10990151 SHA256 ec1d19b05c7a592a316e845ff4c5549c6236cc7ea83423c0fc7831c16161bbbf SHA512 942c28205ffb2c7d3ba767ff68b342ef5b7b9fef72131782635e86682c82a4ea3dad9d5263a42563ded22db573015c9859e49dc20c812f7a6534478b22d8b9a8 WHIRLPOOL 2473c14bcc50c87bfb925e73cc3c4cd2c02915ac498a5e40aeee312ac9873857406e38e8146fabe722250f2d258b6444813d4c47726c16ce4cfceea35f207d3a
DIST groonga-5.0.3.tar.gz 12421501 SHA256 d4f3e9d00cb16c0028cb32422fa666cbbfb32f47597988fd308931274d94cf52 SHA512 c4595054f46e150b0b95b3d1fb6a18098c93471ee0cdeefc54d266a710db57d6b68a6aceb1a61ede5ebb4e1b5518be64b9b96809bd85634b61c84c1923cbf158 WHIRLPOOL bbcf91770eb626dfaf5d01e04b6f4b2f4ee6fff8fad73cdca36c500560ce8d0b9dc606391b1ae0a23d2fd763ba4eddbc69f2eb8b692a5c3c59c1b21745d01de0
DIST groonga-5.0.9.tar.gz 12851324 SHA256 4fb59009dca154ffb53f9b408dc296e6e215f8eda613a8ef184fa634e702d35d SHA512 6e89be8894737616cfcbd0edd92c94a25fb8a2f9c97bd0aab10c2d628664aa328384d6b953516fe96cec5b58fd229c42262caad4785ca9574c759d6d7177fba6 WHIRLPOOL 7f7ac215d4eb0eca0eb18e496a79c6023fe2040f2423c3b4b968d4923b800676c1ad2982880925880ffee5b92ff508b21132ecc2f9b7675612e147adfd13dd6c
DIST groonga-6.1.2.tar.gz 14028916 SHA256 6625d7e1b822da6c29391558fac51e4e3b99145635e96c6eff85e7e33139b0f7 SHA512 cd2dd667608fac856b36a824c5ea285da937cc11b6d4e5ad2f84581f6fbc714b4bb381515ec7b467ddccfad77c77c080000def653d9cdd8725c0f512c7b83f20 WHIRLPOOL ca0b53bb6def465830fb048ac8b83319ccac8e035facb76fb145a8f454336889fef04a8c774fbcfaf32a75cbf938005266f1cf80fc85e55888c4c5ee67bf8bb2
92 changes: 92 additions & 0 deletions app-text/groonga/groonga-6.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,92 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils libtool user

DESCRIPTION="An Embeddable Fulltext Search Engine"
HOMEPAGE="http://groonga.org/"
SRC_URI="http://packages.groonga.org/source/${PN}/${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="abort benchmark debug doc dynamic-malloc-change +exact-alloc-count examples fmalloc futex libedit libevent lzo mecab msgpack +nfkc sphinx static-libs uyield zeromq zlib"

RDEPEND="benchmark? ( >=dev-libs/glib-2.8 )
libedit? ( >=dev-libs/libedit-3 )
libevent? ( dev-libs/libevent )
lzo? ( dev-libs/lzo )
mecab? ( >=app-text/mecab-0.80 )
msgpack? ( dev-libs/msgpack )
sphinx? ( >=dev-python/sphinx-1.0.1 )
zeromq? ( net-libs/zeromq )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
virtual/pkgconfig
sphinx? ( dev-python/sphinx )"

REQUIRED_USE=" abort? ( dynamic-malloc-change ) fmalloc? ( dynamic-malloc-change ) sphinx? ( doc )"

pkg_setup() {
enewgroup groonga
enewuser groonga -1 -1 -1 groonga
}

src_prepare() {
default_src_prepare
elibtoolize
}

src_configure() {
# httpd is a bundled copy of nginx; disabled for security reasons
# prce only is used with httpd
# kytea and libstemmer are not available in portage
# ruby is only used for an http test
econf \
--disable-groonga-httpd \
--without-pcre \
--without-kytea \
--without-libstemmer \
--with-log-path="${EROOT}var/log/${PN}.log" \
--docdir="${EROOT}usr/share/doc/${P}" \
--without-ruby \
$(use_enable abort) \
$(use_enable benchmark) \
$(use_enable debug memory-debug) \
$(use_enable doc document) \
$(use_enable dynamic-malloc-change) \
$(use_enable exact-alloc-count) \
$(use_enable fmalloc) \
$(use_enable futex) \
$(use_enable libedit) \
$(use_with libevent) \
$(use_with lzo) \
$(use_with mecab) \
$(use_with msgpack message-pack "${EROOT}usr") \
$(use_enable nfkc) \
$(use_with sphinx sphinx-build) \
$(use_enable static-libs static) \
$(use_enable uyield) \
$(use_enable zeromq) \
$(use_with zlib)
}

src_install() {
local DOCS=( README.md )
default

prune_libtool_files

newinitd "${FILESDIR}/${PN}.initd" ${PN}
newconfd "${FILESDIR}/${PN}.confd" ${PN}

keepdir /var/{log,lib}/${PN}
fowners groonga:groonga /var/{log,lib}/${PN}

use examples || rm -r "${D}usr/share/${PN}" || die
# Extra init script
rm -r "${D}usr/sbin/groonga-httpd-restart" || die
}

0 comments on commit e48061f

Please sign in to comment.