Skip to content

Commit

Permalink
games-fps/gzdoom: Add '-DNDEBUG' to CXXFLAGS
Browse files Browse the repository at this point in the history
Allows certain mods, like Project Brutality's git master, to work.

See: ZDoom/gzdoom#1279

I've also added a 'debug' useflag that skips 'append-cppflags -DNDEBUG'
just incase.

Package-Manager: Portage-3.0.12, Repoman-3.0.2
Signed-off-by: James McClain <[email protected]>
Closes: gentoo#19121
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
TheGreatMcPain authored and chewi committed Jan 19, 2021
1 parent 9df881b commit e4838ac
Showing 1 changed file with 6 additions and 3 deletions.
9 changes: 6 additions & 3 deletions games-fps/gzdoom/gzdoom-4.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake desktop xdg
inherit cmake desktop xdg flag-o-matic

DESCRIPTION="A modder-friendly OpenGL source port based on the DOOM engine"
HOMEPAGE="https://zdoom.org"
Expand All @@ -14,7 +14,7 @@ LICENSE="Apache-2.0 BSD BZIP2 GPL-3 LGPL-2.1+ LGPL-3 MIT
non-free? ( Activision ChexQuest3 DOOM-COLLECTORS-EDITION freedist WidePix )"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="gtk gtk2 +non-free openmp"
IUSE="debug gtk gtk2 +non-free openmp"

DEPEND="
app-arch/bzip2
Expand Down Expand Up @@ -58,6 +58,9 @@ src_configure() {
-DNO_OPENMP="$(usex !openmp)"
-DBUILD_NONFREE="$(usex non-free)"
)

use debug || append-cppflags -DNDEBUG

cmake_src_configure
}

Expand Down

0 comments on commit e4838ac

Please sign in to comment.