Skip to content

Commit

Permalink
games-strategy/s25rttr: fix build w/ gcc 13
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/891713
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jan 23, 2023
1 parent e5f8dba commit e4dcbf5
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 1 deletion.
50 changes: 50 additions & 0 deletions games-strategy/s25rttr/files/s25rttr-0.9.5-gcc-13.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
https://bugs.gentoo.org/891713
https://github.com/Return-To-The-Roots/s25client/pull/1548
https://github.com/Return-To-The-Roots/libsiedler2/pull/21

From d59abd4b565cd6f11dd64f6e4f497c9797e52c5a Mon Sep 17 00:00:00 2001
From: Sam James <[email protected]>
Date: Mon, 23 Jan 2023 01:49:47 +0000
Subject: [PATCH] LanGameInfo: Add missing <cstdint> include

GCC 13 (as usual for new compiler releases) shuffles around some
internal includes and so <cstdint> etc is no longer transitively included.

See https://www.gnu.org/software/gcc/gcc-13/porting_to.html.

Closes: https://github.com/Return-To-The-Roots/libsiedler2/issues/20
Bug: https://bugs.gentoo.org/891713
--- a/libs/s25main/gameTypes/LanGameInfo.h
+++ b/libs/s25main/gameTypes/LanGameInfo.h
@@ -4,6 +4,7 @@

#pragma once

+#include <cstdint>
#include <string>

class Serializer;

From 6a289fa3a3f50f0967a072292f3e0c628144ab8d Mon Sep 17 00:00:00 2001
From: Sam James <[email protected]>
Date: Mon, 23 Jan 2023 01:47:19 +0000
Subject: [PATCH] oem: Add missing <cstdint> include

GCC 13 (as usual for new compiler releases) shuffles around some
internal includes and so <cstdint> etc is no longer transitively included.

See https://www.gnu.org/software/gcc/gcc-13/porting_to.html.

Closes: https://github.com/Return-To-The-Roots/libsiedler2/issues/20
Bug: https://bugs.gentoo.org/891713
--- a/external/libsiedler2/src/oem.cpp
+++ b/external/libsiedler2/src/oem.cpp
@@ -4,6 +4,7 @@

#include "oem.h"
#include <array>
+#include <cstdint>

namespace libsiedler2 {


3 changes: 2 additions & 1 deletion games-strategy/s25rttr/s25rttr-0.9.5.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand Down Expand Up @@ -41,6 +41,7 @@ BDEPEND="

PATCHES=(
"${FILESDIR}"/${PN}-0.9.0_pre20200723-cmake_lua_version.patch
"${FILESDIR}"/${PN}-0.9.5-gcc-13.patch
)

S="${WORKDIR}/${MY_PN}_v${PV}"
Expand Down

0 comments on commit e4dcbf5

Please sign in to comment.