Skip to content

Commit

Permalink
gnome-base/nautilus: Version bump to 44.2
Browse files Browse the repository at this point in the history
Signed-off-by: Guillermo Joandet <[email protected]>
Closes: gentoo#31196
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
flint2 authored and mattst88 committed May 28, 2023
1 parent 445d465 commit e4e24a0
Show file tree
Hide file tree
Showing 2 changed files with 120 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-base/nautilus/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST nautilus-42.2.tar.xz 3254912 BLAKE2B 303b52fe9bbdb8e437a447004dcd284ee0c66ecaa11db45c52cf8c831f52a764efa03476d69f74840289f200c49b917bc329487bd87d3e776ea5dc1a6ea9b413 SHA512 2b3ba2990b00bbc3abf771b83b9b0a7c1a8b107b1b4955a45879f7d28add713d326bbe84d70056058073edfc3c7b7891547af77b8a34f94fe1b9ca047c76e9c9
DIST nautilus-44.1.tar.xz 3192400 BLAKE2B dfd02c6cdd23a723ba65a93953e80a859a22c6104cb1faeb24a81d9031b99ffc4cc9b3dd10743f928b36da3bf7c33500dc23f9f37530845b54cb250660513b9c SHA512 fa7c029db1c8c7e13d22e692e4e107dbadb136aa8313de1bc07b826bf681af012d9a4a70c3ad4def0f348b2acb103455edcb2f7b1c804f525e337b4417fb6db2
DIST nautilus-44.2.tar.xz 3190788 BLAKE2B 90447c51b044fd4afd2439a36c24a18cded2fac5117ea708355f25c0a28ea1974a16e05685ac2d34b5c97afbef59989241d90f53c263211255513adcf03d1cc6 SHA512 1bec622d204e9ae01dfcab37e3263927c723ab1e143729190777c45cae6f03d6f601fd30bc1a75dbba63b2b69f212e888bacf2eebad118f8b4c5e09134aac4b6
119 changes: 119 additions & 0 deletions gnome-base/nautilus/nautilus-44.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,119 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit gnome.org gnome2-utils meson readme.gentoo-r1 virtualx xdg

DESCRIPTION="Default file manager for the GNOME desktop"
HOMEPAGE="https://wiki.gnome.org/Apps/Nautilus"

LICENSE="GPL-3+ LGPL-2.1+"
SLOT="0"
IUSE="gnome +gstreamer gtk-doc +introspection +previewer selinux sendto"
REQUIRED_USE="gtk-doc? ( introspection )"

KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"

DEPEND="
>=dev-libs/glib-2.72.0:2
>=media-libs/gexiv2-0.14.0
>=x11-libs/gdk-pixbuf-2.30.0:2
gstreamer? ( media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0 )
>=app-arch/gnome-autoar-0.4.4
>=gnome-base/gnome-desktop-43:4=
>=gnome-base/gsettings-desktop-schemas-42
>=gui-libs/gtk-4.10.3:4[introspection?]
>=gui-libs/libadwaita-1.3.0:1
>=dev-libs/libportal-0.5:=[gtk]
>=x11-libs/pango-1.28.3
selinux? ( >=sys-libs/libselinux-2.0 )
>=app-misc/tracker-3.0:3
>=dev-libs/libxml2-2.7.8:2
>=net-libs/libcloudproviders-0.3.1
introspection? ( >=dev-libs/gobject-introspection-1.54:= )
"
RDEPEND="${DEPEND}
>=app-misc/tracker-miners-3.0:3=
" # uses org.freedesktop.Tracker.Miner.Files gsettings schema from tracker-miners
BDEPEND="
>=dev-util/gdbus-codegen-2.51.2
dev-util/glib-utils
gtk-doc? (
app-text/docbook-xml-dtd:4.1.2
dev-util/gi-docgen
)
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"
PDEPEND="
gnome? ( x11-themes/adwaita-icon-theme )
previewer? ( >=gnome-extra/sushi-0.1.9 )
sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
>=gnome-base/gvfs-1.14[gtk(+)]
" # Need gvfs[gtk] for recent:/// support; always built (without USE=gtk) since gvfs-1.34

PATCHES=(
"${FILESDIR}"/43.0-optional-gstreamer.patch # Allow controlling audio-video-properties build
)

src_prepare() {
default
xdg_environment_reset

# Disable -Werror
sed -e '/-Werror=/d' -i meson.build || die

if use previewer; then
DOC_CONTENTS="nautilus uses gnome-extra/sushi to preview media files.
To activate the previewer, select a file and press space; to
close the previewer, press space again."
fi

# Disable test-nautilus-search-engine-tracker; bug #831170
sed -e '/^tracker_tests = /{n;N;N;d}' -i test/automated/displayless/meson.build || die
}

src_configure() {
local emesonargs=(
$(meson_use gtk-doc docs)
-Dextensions=true # image file properties, sendto support; also required for -Dgstreamer=true
$(meson_use gstreamer) # gstreamer audio-video-properties extension
$(meson_use introspection)
-Dpackagekit=false
$(meson_use selinux)
-Dprofiling=false
-Dtests=$(usex test all none)
)
meson_src_configure
}

src_install() {
use previewer && readme.gentoo_create_doc
meson_src_install
}

src_test() {
# Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
gnome2_environment_reset
# TODO: Tests require tracker testutils (e.g. tracker-sandbox), which may
# need some sorting out with tracker use flag deps
virtx meson_src_test
}

pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update

if use previewer; then
readme.gentoo_print_elog
else
elog "To preview media files, emerge nautilus with USE=previewer"
fi
}

pkg_postrm() {
xdg_pkg_postrm
gnome2_schemas_update
}

0 comments on commit e4e24a0

Please sign in to comment.