Skip to content

Commit

Permalink
dev-python/python-glanceclient: Bump to 4.2.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 16, 2022
1 parent 9662d2a commit e50279e
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/python-glanceclient/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST python-glanceclient-4.1.0.tar.gz 204252 BLAKE2B 484753886663f10b93fc2d9a0c3c2a1359324d989edfa26c0fe26cb7ab74897a5a81a3fac201d53af375d111e0b1e043fce79b1f3d3f153854bd9f63db756a9f SHA512 413d5a77c4b014f6300513552aca33a04e9a34e9bfa9c93ecc9008c79123ba7f20e527f3ad7506d066c0d215aa7fbf57a589a5f015fe1bc52479b8c57c760adf
DIST python-glanceclient-4.2.0.tar.gz 204378 BLAKE2B ee869971f769dd01da2dcf7e1d7ca07e120b5a2ad5a210db7b6cf813a0bb14bb00f8d7f64a4a5c03de61983abfad0448ff3ad9ab4b9acb485a897ae39e4c9409 SHA512 4977db9650ec35ad663fdaa9c576fb1c63efddb9f3df8a92da9e97e530bb5a63016e2492f81239fbb4d01cf260e673c2d489566c10483d2bf6ff9e0653e3bd21
53 changes: 53 additions & 0 deletions dev-python/python-glanceclient/python-glanceclient-4.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )

inherit distutils-r1

DESCRIPTION="A client for the OpenStack Glance API"
HOMEPAGE="
https://opendev.org/openstack/python-glanceclient/
https://github.com/openstack/python-glanceclient/
https://pypi.org/project/python-glanceclient/
"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"

RDEPEND="
>=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
>dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
>=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
>=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
<dev-python/warlock-2[${PYTHON_USEDEP}]
>=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
"
BDEPEND="
>dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
test? (
dev-python/ddt[${PYTHON_USEDEP}]
dev-python/fixtures[${PYTHON_USEDEP}]
dev-python/requests-mock[${PYTHON_USEDEP}]
dev-python/tempest[${PYTHON_USEDEP}]
dev-python/testscenarios[${PYTHON_USEDEP}]
dev-python/testtools[${PYTHON_USEDEP}]
dev-python/prettytable[${PYTHON_USEDEP}]
)
"

distutils_enable_tests unittest

python_test() {
# functional tests require cloud instance access
eunittest -b glanceclient/tests/unit
}

0 comments on commit e50279e

Please sign in to comment.