Skip to content

Commit

Permalink
dev-libs/dbus-glib: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
mrueg committed Jan 19, 2016
1 parent 76a5639 commit e53c846
Show file tree
Hide file tree
Showing 2 changed files with 96 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/dbus-glib/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST dbus-glib-0.102.tar.gz 783792 SHA256 6964ed585bb8149a14ab744b5ded5e77cf71ec5446e6dcc5fcf5eebcc52df29c SHA512 9bf4b33dd264eaed9ade0e35f0ad47986c31bd5e3de4d3e2fcee66a9be87000b6121bc810b9a5a24eca53190d98323b871dc78f341df8e05bd0247b096cf778f WHIRLPOOL b83f12877118dca1797c935f57a6ae664fbfc70c4d2fb2d95d2cf11abb7c326a098f336225ffb9030fac00a33d988a30038e2734721fc1ddbb5297f864e01bcf
DIST dbus-glib-0.104.tar.gz 793417 SHA256 bfc1f1a82bfc3ec3ecafe04d0e87bab7e999f50dce4f4a34d0b89caf6bd821f6 SHA512 eff599f169976055545b51459d77845002d8bc7e8dcd056cec2bf83836d07c66b03baed2023bc87a6d7c021d35c744987830f8ed6f9c3391a49ee199db85134b WHIRLPOOL 6e757dee52ea11a7e43cc22a090243cd77ae0b38439fead755c78a6e8b7d6e7e2b1bb1218e23396513e33ef555e35b556f3b333a190077fd9472288e3e96ce91
DIST dbus-glib-0.106.tar.gz 793343 SHA256 b38952706dcf68bad9c302999ef0f420b8cf1a2428227123f0ac4764b689c046 SHA512 13a1d4600add29d29dbb8d1271570e6c04f70ddff0862d28fcb7df774bfa76a961f90303f897f3b970070eb959e909d5d02a94941e2edd8ba315b9aaa3a602cb WHIRLPOOL 059cb497af2fe957fe3234db62c629eba3581a119211d05e21acac6b0ce9b15614c57f8d7ea63264a688498691deee0fa3035c7413a48c9f3679a196c159d867
95 changes: 95 additions & 0 deletions dev-libs/dbus-glib/dbus-glib-0.106.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,95 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit bash-completion-r1 eutils multilib-minimal

DESCRIPTION="D-Bus bindings for glib"
HOMEPAGE="http://dbus.freedesktop.org/"
SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"

LICENSE="|| ( GPL-2 AFL-2.1 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x86-solaris"
IUSE="debug static-libs test"

CDEPEND="
>=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
>=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
>=sys-apps/dbus-1.8[${MULTILIB_USEDEP}]
"
DEPEND="${CDEPEND}
>=dev-util/gtk-doc-am-1.14
virtual/pkgconfig
"
RDEPEND="${CDEPEND}
abi_x86_32? (
!<app-emulation/emul-linux-x86-baselibs-20131008-r8
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
)
"

DOCS=( AUTHORS ChangeLog HACKING NEWS README )

set_TBD() {
# out of sources build dir for make check
export TBD="${BUILD_DIR}-tests"
}

src_prepare() {
epatch_user
}

multilib_src_configure() {
local myconf=(
--localstatedir="${EPREFIX}"/var
--enable-bash-completion
--disable-gtk-doc
$(use_enable debug asserts)
$(use_enable static-libs static)
)

ECONF_SOURCE="${S}" econf "${myconf[@]}"

ln -s "${S}"/doc/reference/html doc/reference/html #460042

if use test; then
set_TBD
mkdir "${TBD}"
cd "${TBD}"
einfo "Running configure in ${TBD}"
ECONF_SOURCE="${S}" econf \
"${myconf[@]}" \
$(use_enable test checks) \
$(use_enable test tests) \
$(use_enable test asserts) \
$(use_with test test-socket-dir "${T}"/dbus-test-socket)
fi
}

multilib_src_compile() {
emake

if use test; then
set_TBD
cd "${TBD}"
einfo "Running make in ${TBD}"
emake
fi
}

multilib_src_test() {
set_TBD
cd "${TBD}"
emake check
}

multilib_src_install_all() {
einstalldocs

newbashcomp "${ED}"/etc/bash_completion.d/dbus-bash-completion.sh dbus-send
rm -rf "${ED}"/etc/bash_completion.d || die

prune_libtool_files
}

0 comments on commit e53c846

Please sign in to comment.