Skip to content

Commit

Permalink
dev-python/urwid: Bump to 2.6.14
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jun 13, 2024
1 parent eba0f28 commit e544f20
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/urwid/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST urwid-2.6.12.tar.gz 847508 BLAKE2B 9790f2bcb768ff859115c1eb1dd03899e49eff41a56540d24ab0a2340b43c23e0572bfe6b689033a37c579ed4860e67a6fb3ade913c5a9c9d68d4a7bb41e8dab SHA512 1b2c7de9f523fe6c80155fc039a2b9e9d416c27f7d52a41911443b0a057739526b755fcb9c901ce99ab8e1e7d1bb5ff2be5ab7c0251554d9d933c0235b44a8e8
DIST urwid-2.6.13.tar.gz 847604 BLAKE2B ce2294f8c1eaf6609790f18e1312eec66fce610832d510a057c8af773675b4ac2ce47c027be10beff14c1e0d67bc9e59cd372ee612e3357c88d3d89fe4d4cb3f SHA512 9989c3f906cca38a32baccef3c4717deb964f15b5cb08135be75d3e2a5a26f4d64cfe6cc2f58cba5e0ba8da1fb52ef71a591a88dbed9f8e2c80960933dff3537
DIST urwid-2.6.14.tar.gz 847848 BLAKE2B 3528c89b34a9846b6ee8524b789c80c0cb353185d6d819a179e099753cc9a5aa8fbbcdad7f80190543ad8f68126246359bb94d5e5b4112930f023b2c1619f09d SHA512 289ada7949119889ccfdd547266f423a9a6c0368c7ead20716d4f503f42c737864be84a9feff66ae036a9f7e230d338226e259f5d552e17d439a49fdbfc86149
41 changes: 41 additions & 0 deletions dev-python/urwid/urwid-2.6.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} )
PYTHON_REQ_USE="ncurses"

inherit distutils-r1 optfeature pypi

DESCRIPTION="Curses-based user interface library for Python"
HOMEPAGE="
https://urwid.org/
https://pypi.org/project/urwid/
https://github.com/urwid/urwid/
"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="examples"

RDEPEND="
dev-python/typing-extensions[${PYTHON_USEDEP}]
dev-python/wcwidth[${PYTHON_USEDEP}]
"
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
"

distutils_enable_tests unittest

python_install_all() {
use examples && dodoc -r examples
distutils-r1_python_install_all
}

pkg_postinst() {
optfeature "Trio event loop" "dev-python/trio"
}

0 comments on commit e544f20

Please sign in to comment.