Skip to content

Commit

Permalink
gui-apps/mako: initial add of gui-apps/mako
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
prometheanfire committed Apr 5, 2019
1 parent fc698d3 commit e56e758
Show file tree
Hide file tree
Showing 4 changed files with 117 additions and 0 deletions.
1 change: 1 addition & 0 deletions gui-apps/mako/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST mako-1.2.tar.gz 34443 BLAKE2B d505cbc7d25755ef3880adceaf8e33c277a90583c37ebd2691cd3d8d142f19f7eedca2ad167c0174723706c6f0a9b0688ddb34ed824e8231330265f1b5e3d645 SHA512 2552590f690a9749e9ef897052ca6aecf70eb01d77b1afe21335c84e257c6c8347abbd7f33150d561e8f52a9ae3a91c7a199a93cecf64a305934886522fc1454
46 changes: 46 additions & 0 deletions gui-apps/mako/mako-1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway."
HOMEPAGE="https://github.com/emersion/mako"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
else
SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="MIT"
SLOT="0"
IUSE=""

DEPEND="
dev-libs/wayland
x11-libs/pango
x11-libs/cairo
|| (
sys-apps/systemd
sys-auth/elogind
)
sys-apps/dbus[user-session]
"
RDEPEND="
${DEPEND}
"
BDEPEND="
virtual/pkgconfig
app-text/scdoc
"

src_configure() {
local emesonargs=(
"-Dwerror=false"
)
meson_src_configure
}
51 changes: 51 additions & 0 deletions gui-apps/mako/mako-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway."
HOMEPAGE="https://github.com/emersion/mako"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
else
SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="MIT"
SLOT="0"
IUSE="+icons"

DEPEND="
dev-libs/wayland
x11-libs/pango
x11-libs/cairo
|| (
sys-apps/systemd
sys-auth/elogind
)
sys-apps/dbus[user-session]
icons? (
x11-libs/gtk+:3
x11-libs/gdk-pixbuf
)
"
RDEPEND="
${DEPEND}
"
BDEPEND="
virtual/pkgconfig
app-text/scdoc
"

src_configure() {
local emesonargs=(
-Dicons=$(usex icons enabled disabled)
"-Dwerror=false"
)
meson_src_configure
}
19 changes: 19 additions & 0 deletions gui-apps/mako/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Matthew Thode</name>
</maintainer>
<longdescription lang="en">
A lightweight notification daemon for Wayland. Works on Sway.
</longdescription>
<use>
<flag name="icons">Enable support for icons</flag>
</use>
<upstream>
<remote-id type="github">emmersion/mako</remote-id>
<bugs-to>https://github.com/emersion/mako/issues</bugs-to>
<changelog>https://github.com/emersion/mako/releases</changelog>
</upstream>
</pkgmetadata>

0 comments on commit e56e758

Please sign in to comment.