Skip to content

Commit

Permalink
games-simulation/openrct2: version bump to 0.1.2
Browse files Browse the repository at this point in the history
also force the build system to create a shared library used by both
binaries

Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
hvraven authored and mgorny committed May 9, 2018
1 parent b3cd383 commit e5a5da3
Show file tree
Hide file tree
Showing 2 changed files with 106 additions and 0 deletions.
2 changes: 2 additions & 0 deletions games-simulation/openrct2/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST openrct2-0.1.1.tar.gz 6284135 BLAKE2B 71ac2671c42fb679f5430ef0d0bd5e05d112aebd20b4b59e05e3527bacf24137b81bcedc72f9cc86cbf0b7612d6dc14c82881a828108aa5b16b8ddeeed78c46e SHA512 fd84907819ac317af88c0446afcb04acdb43cd6671f0837f1294191aacf58e93887d46e6eb28d86f558577f4e7c834bc42a9ec486f67e0b64cb7bc0cc1bda427
DIST openrct2-0.1.2.tar.gz 6769785 BLAKE2B 0cc6ef6c68c1db6c822dd6038bc2d115f487a52b5891316273ee36db1713913baa2f119dabace88a37c16f87c90b14cf84df75a24b26b22571e98966afd2adbc SHA512 489dac96e1eda1449680f98a4b500eeb7b3f1ffbdaa5a5c701300071eb3a7862c65fa5a81e769083927b95a14914db54307724756a9841cff0c769c9e5471adc
DIST openrct2-title-sequence-v0.1.0.zip 1766393 BLAKE2B 19612ba78572c4f271349387a24fc9caf389552ad78841ed86ff069c20686da339c83cabe041a1ae240055721984372f1ef20bd009f1ac8b38bf3ff82297b29a SHA512 0d1b47c5fc5d1d9e5580b30d0f43d5532b388f1a5685060ca9313ec2f76c61a5fc96b8aa37689072b71edd9fb1aedddd46fa38c237ccb7198841d7bc33bf2a2b
DIST openrct2-title-sequence-v0.1.2.zip 4073116 BLAKE2B a36fb07e8da62afce129f2224f4cf5cc226922094132a3dc515fda1f02e0f8bbe07c973363f824ae58a54a26f252ad96f3f673bf5f142be5c964f45b6f712ed6 SHA512 7592c5397ceb27347c127ae5c4f8e11d7ef2ff23c97f627b354f941894420f546ffdcff88e2348e42c82d182ccf620e739c745d894a9b5650a0d7d028b68a106
104 changes: 104 additions & 0 deletions games-simulation/openrct2/openrct2-0.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,104 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils gnome2-utils xdg-utils

DESCRIPTION="An open source re-implementation of RollerCoaster Tycoon 2"
HOMEPAGE="https://openrct2.website/"
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/OpenRCT2/OpenRCT2.git"
EGIT_BRANCH="develop"
inherit git-r3
SRC_URI=""
else
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/OpenRCT2/OpenRCT2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/OpenRCT2-${PV}"
fi

TSV="${PV}"
SRC_URI+=" https://github.com/OpenRCT2/title-sequences/releases/download/v${TSV}/title-sequence-v${TSV}.zip -> ${PN}-title-sequence-v${TSV}.zip "

LICENSE="GPL-3"
SLOT="0"
IUSE="libressl +multiplayer opengl test truetype +twitch"

RDEPEND="
>=dev-libs/jansson-2.5
>=dev-libs/libzip-1.0
media-libs/libpng:0=
media-libs/libsdl2
|| (
media-libs/speexdsp
<media-libs/speex-1.2.0
)
multiplayer? (
libressl? ( dev-libs/libressl:0= )
!libressl? ( dev-libs/openssl:0= )
)
opengl? ( virtual/opengl )
truetype? (
media-libs/sdl2-ttf
media-libs/fontconfig
)
twitch? ( net-misc/curl[ssl] )
"
DEPEND="${RDEPEND}
app-arch/unzip
test? ( dev-cpp/gtest )
"

src_unpack() {
if [[ ${PV} == 9999 ]]; then
git-r3_src_unpack
else
unpack ${P}.tar.gz
fi

mkdir -p "${S}/data/title" || die
pushd "${S}/data/title" || die
unpack ${PN}-title-sequence-v${TSV}.zip
popd || die
}

src_prepare() {
sed -i CMakeLists.txt -e 's/-Werror//' || die

cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
-DDISABLE_HTTP_TWITCH="$(usex !twitch)"
-DDISABLE_NETWORK="$(usex !multiplayer)"
-DDISABLE_OPENGL="$(usex !opengl)"
-DDISABLE_TTF="$(usex !truetype)"
-DWITH_TESTS="$(usex test)"
-DDOWNLOAD_TITLE_SEQUENCES=OFF
-DDISABLE_RCT2_TESTS=ON
-DSYSTEM_GTEST=ON
-DBUILD_SHARED_LIBS=ON
)

cmake-utils_src_configure
}

pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
ewarn ""
ewarn "You need the original RollerCoaster Tycoon 2 files to play this game."
ewarn "See: https://github.com/OpenRCT2/OpenRCT2/wiki/Required-RCT2-files#how-to-retrieve"
ewarn ""
fi
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

0 comments on commit e5a5da3

Please sign in to comment.