Skip to content

Commit

Permalink
app-misc/pax-utils: version bump to 1.1
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Aug 20, 2015
1 parent f373afd commit e5f148d
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/pax-utils/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -15,3 +15,4 @@ DIST pax-utils-1.0.3.tar.xz 621460 SHA256 8535a94e1f77841da92d5526d2935abb786437
DIST pax-utils-1.0.4.tar.xz 622280 SHA256 f7e16cf22d4dc431feb49d3fad21fd7f9703ec3a9b5bde24fe426891a376d5f3 SHA512 73051b77cc6c0411b4747082a806a620edc60eb89b061208246fd22dc107cfbf92767d56c012fd57eda1fb8cd40365b6b4f87fdc2217c9437be7d71a407a0f66 WHIRLPOOL 5ab2fd742a194e8e4e8381d8a721da4d9fe8c0fb5dbaf873d2887abf4741263f6072191eddc033b6a572faa92ff5dde1bfedd68ad053f4488101df935acd0b3b
DIST pax-utils-1.0.5.tar.xz 622532 SHA256 f69a9938e4af7912d26d585094bc0203e43571a990fdd048319088a8b8ad906f SHA512 e8e07acf8295d90f30ea464e8060ae66ffabfa79a22b44e8c00eebf532ef78eb987eb7b69ecbf9f5bd25ec3e3964a746f546abbf111e065c5683c9f47194d026 WHIRLPOOL 0ac1ec6191106f20da3ba2a1a7ffe9ad7db184d1b79d13800b0844b7e250eadc750735dfeba70858d0b845669812be0fd761c26036d022322f251024bb437272
DIST pax-utils-1.0.tar.xz 619104 SHA256 c39fcc181c7c6a03527687d9977e1c2ce2b47b28918426a057d56b43a429e312 SHA512 ec44e5f848e64ba70eeb2ca670189c84a0b0d36ee745ae956ee56d291dd3c5b3fe56527867a52e264babfbaaad49ec59338fadc297256a7a4708cf65f97db4c5 WHIRLPOOL 86f91917d7723066a849f2225987b9739f3c484626735c77ee27286ea1785e316b374110226688ad8d380b90b5aa140e1060cc2411cd6d1d250a1918ed33d575
DIST pax-utils-1.1.tar.xz 627392 SHA256 97ed475ae9f91cf5ca47eeb39abe6033db77e480469dad7c7823ed16be2475ad SHA512 24569a8bbcd635b163f1dc84d4a74dac2e89fc5a18bdb0ead8db78dde5f0661f3d4d51118818f028bc5359447a2d9156ab394ffb26b5c64e377f3bf4536cecb5 WHIRLPOOL e5d1782904bd31ad93e09486ee01bf0af7a33db7bde6eaefdfeaaa462632b1f66633065509b7b79bf493030b0c104472446f7aaf7fbc549564715ffebe5eeb38
55 changes: 55 additions & 0 deletions app-misc/pax-utils/pax-utils-1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="4"

inherit eutils toolchain-funcs unpacker

DESCRIPTION="ELF related utils for ELF 32/64 binaries that can check files for security relevant properties"
HOMEPAGE="https://wiki.gentoo.org/index.php?title=Project:Hardened/PaX_Utilities"
SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.xz
http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.xz
http://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
IUSE="caps python seccomp"

RDEPEND="caps? ( sys-libs/libcap )
python? ( dev-python/pyelftools )
seccomp? ( sys-libs/libseccomp )"
DEPEND="${RDEPEND}
app-arch/xz-utils"

_emake() {
emake \
USE_CAP=$(usex caps) \
USE_PYTHON=$(usex python) \
USE_SECCOMP=$(usex seccomp) \
"$@"
}

src_configure() {
# Avoid slow configure+gnulib+make if on an up-to-date Linux system
if use prefix || ! use kernel_linux || \
has_version '<sys-libs/glibc-2.10'
then
econf $(use_with caps) $(use_with python) $(use_with seccomp)
else
tc-export CC
fi
}

src_compile() {
_emake
}

src_test() {
_emake check
}

src_install() {
_emake DESTDIR="${ED}" PKGDOCDIR='$(DOCDIR)'/${PF} install
}

0 comments on commit e5f148d

Please sign in to comment.