Skip to content

Commit

Permalink
app-misc/pax-utils: version bump to 1.1.2
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Sep 12, 2015
1 parent 40c56e0 commit e612fac
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/pax-utils/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,4 +5,5 @@ DIST pax-utils-1.0.4.tar.xz 622280 SHA256 f7e16cf22d4dc431feb49d3fad21fd7f9703ec
DIST pax-utils-1.0.5.tar.xz 622532 SHA256 f69a9938e4af7912d26d585094bc0203e43571a990fdd048319088a8b8ad906f SHA512 e8e07acf8295d90f30ea464e8060ae66ffabfa79a22b44e8c00eebf532ef78eb987eb7b69ecbf9f5bd25ec3e3964a746f546abbf111e065c5683c9f47194d026 WHIRLPOOL 0ac1ec6191106f20da3ba2a1a7ffe9ad7db184d1b79d13800b0844b7e250eadc750735dfeba70858d0b845669812be0fd761c26036d022322f251024bb437272
DIST pax-utils-1.0.tar.xz 619104 SHA256 c39fcc181c7c6a03527687d9977e1c2ce2b47b28918426a057d56b43a429e312 SHA512 ec44e5f848e64ba70eeb2ca670189c84a0b0d36ee745ae956ee56d291dd3c5b3fe56527867a52e264babfbaaad49ec59338fadc297256a7a4708cf65f97db4c5 WHIRLPOOL 86f91917d7723066a849f2225987b9739f3c484626735c77ee27286ea1785e316b374110226688ad8d380b90b5aa140e1060cc2411cd6d1d250a1918ed33d575
DIST pax-utils-1.1.1.tar.xz 627640 SHA256 9ea1f28b3665da08fd80384e56d2a71bfa9f279983e683a162eb4993b2df8d3e SHA512 a8680f9bc99edef56d24175b5967dd967daaa8ae40c0c68f0e9ff3a23ac90a7cb341c99a47a0f6e29504c3f2740039920258a69267ee89549525d02306a8d70e WHIRLPOOL 7ee993224d54d82527c99d9d46c30f2bca0e464660b2ebedaf43076287894247db8111e3f5b558140f03b743939939849f03bcb134b2ac7776bb30553a183c45
DIST pax-utils-1.1.2.tar.xz 627732 SHA256 49390215f6a4773a9c0a99a6de90ff768d13ce2eb4ba1a869603b81f697fce3e SHA512 7a97ff3f68ef67084d1785c95aed2bef5c3bd6fe0c67b96310bd236dc0a403ab5fa86d2b719bdc493b6d6ce07e43af41cc1ff3aa0bd726f2896494079996bff7 WHIRLPOOL c94e1c55a183ce6a6d44a0993ca6c3c34d41f1fad43dabdc9994357747a159e1578e61f13634c4379d324640c4b1d67073e82992f521964acd64598fa7c342f8
DIST pax-utils-1.1.tar.xz 627392 SHA256 97ed475ae9f91cf5ca47eeb39abe6033db77e480469dad7c7823ed16be2475ad SHA512 24569a8bbcd635b163f1dc84d4a74dac2e89fc5a18bdb0ead8db78dde5f0661f3d4d51118818f028bc5359447a2d9156ab394ffb26b5c64e377f3bf4536cecb5 WHIRLPOOL e5d1782904bd31ad93e09486ee01bf0af7a33db7bde6eaefdfeaaa462632b1f66633065509b7b79bf493030b0c104472446f7aaf7fbc549564715ffebe5eeb38
58 changes: 58 additions & 0 deletions app-misc/pax-utils/pax-utils-1.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="4"

inherit eutils toolchain-funcs unpacker

DESCRIPTION="ELF related utils for ELF 32/64 binaries that can check files for security relevant properties"
HOMEPAGE="https://wiki.gentoo.org/index.php?title=Project:Hardened/PaX_Utilities"
SRC_URI="mirror://gentoo/${P}.tar.xz
http://dev.gentoo.org/~solar/pax/${P}.tar.xz
http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
IUSE="caps debug python seccomp"

RDEPEND="caps? ( >=sys-libs/libcap-2.24 )
python? ( dev-python/pyelftools )
seccomp? ( sys-libs/libseccomp )"
DEPEND="${RDEPEND}
caps? ( virtual/pkgconfig )
seccomp? ( virtual/pkgconfig )
app-arch/xz-utils"

_emake() {
emake \
USE_CAP=$(usex caps) \
USE_DEBUG=$(usex debug) \
USE_PYTHON=$(usex python) \
USE_SECCOMP=$(usex seccomp) \
"$@"
}

src_configure() {
# Avoid slow configure+gnulib+make if on an up-to-date Linux system
if use prefix || ! use kernel_linux || \
has_version '<sys-libs/glibc-2.10'
then
econf $(use_with caps) $(use_with debug) $(use_with python) $(use_with seccomp)
else
tc-export CC
fi
}

src_compile() {
_emake
}

src_test() {
_emake check
}

src_install() {
_emake DESTDIR="${ED}" PKGDOCDIR='$(DOCDIR)'/${PF} install
}

0 comments on commit e612fac

Please sign in to comment.