Skip to content

Commit

Permalink
dev-embedded/avr-libc: Bump to 2.1.0, drop IUSE="doc"
Browse files Browse the repository at this point in the history
Bump to the new version and EAPI 8. There is an issue with upstream's
distfile signature for the HTML documentation, so dropping for now. IMHO we
should restore the flag and doc installation as soon as upstream's signature
is fixed.
Man pages are not affected as they are part of the main distfiles archive.

Bug: https://bugs.gentoo.org/837146
Signed-off-by: Nils Freydank <[email protected]>
Signed-off-by: Ulrich Müller <[email protected]>
  • Loading branch information
holgersson32644 authored and ulm committed Jun 8, 2022
1 parent ef87bc9 commit e61d77f
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-embedded/avr-libc/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,5 @@
DIST avr-libc-2.0.0.tar.bz2 3590893 BLAKE2B cc628f5f55d12c78ca9215e3e37b4a0061feae3c7c19653384b5d789fb6e1c70efe420631bf987379ae5524ec0f65c6df459eaad0fcfb80833cc4732ed5e796b SHA512 fc8d062043d633350dbe05978935dcb8028257a4f1013f246af9658aef0671def19ac11577d1ee9302df68df1b8cf030b22441d96852e185db212263aacabea6
DIST avr-libc-2.1.0.tar.bz2 3638672 BLAKE2B b17f3c4971221abe78d4f1d749c6f093e6fcf77b3435bc280af6025bf1c263a4d4d71c55c285ab7d7b458b361baa1d8b928f3ff706510c22b8c6d9f594c44abc SHA512 207b8844353c45172cc819cd5e694bbfe7cd281359cd01cff520f1e70226852d708f1a4fc2e841b2ceb8e3f7d19f2ce45a3f499aee4a25eeb5f6f0aa919611c8
DIST avr-libc-manpages-2.0.0.tar.bz2 151137 BLAKE2B 7fbaa9c1014e8cf9b4caac723b57f9c24272da458b987ba302730116437bb3a5b49296c6804d857b421e6f71f2c4efda959d278ebcc14aba35fdd44a958dfca8 SHA512 8b4aaa6ae176076171e90e629e0e6142c4c56f9cc4f1640432384276df2f7b457f5137739535b07b9cede9b5b2e564db7fe200203faa4e2d0cd9874432507823
DIST avr-libc-manpages-2.1.0.tar.bz2 149031 BLAKE2B 3a2ab8b17ff4954cbe8ba1b1d7751b4d50993559eecb58315b5bcd5a6913f72a2c1138e2bf25f075e89bc7e5d45f00e5e1172b02de84e729c25abed7bdec8754 SHA512 a6fc16b5aa60c25ba1230c0be213bda173f8f437bc71553dc04974cd14e3b9c8ea0abb3a25eac2b6517d34e912880db8eb73fec4a5d5374aa5172e14acbf4fa4
DIST avr-libc-user-manual-2.0.0.tar.bz2 932920 BLAKE2B d3190af26dbe38719bc78e73de31af1ce69d885b928f48a4fb9ccd145a33f19f71c017253ad16eadc641fc88495c642dd5fd1668c6bebddf7d813f70db01a3f6 SHA512 246180be1f793b46335a49f33028ff59bd7cc06ca3d8627309521801e405e0e1305663a2c0760521467e75732ad513749bf707732b59fb17744e51acda9bb2c6
72 changes: 72 additions & 0 deletions dev-embedded/avr-libc/avr-libc-2.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="8"

CHOST="avr"
CTARGET="avr"

inherit flag-o-matic

DESCRIPTION="C library for Atmel AVR microcontrollers"
HOMEPAGE="http://www.nongnu.org/avr-libc/"
SRC_URI="https://savannah.nongnu.org/download/avr-libc/${P}.tar.bz2
https://savannah.nongnu.org/download/avr-libc/${PN}-manpages-${PV}.tar.bz2"

LICENSE="BSD"
SLOT="0"
# 'amd64' is a blessed placeholder for crossdev. It could
# be any other arch. See bug #620316#c5
# Don't add more arches to KEYWORDS.
KEYWORDS="amd64"
IUSE="headers-only"

DEPEND=">=sys-devel/crossdev-0.9.1"
[[ ${CATEGORY/cross-} != ${CATEGORY} ]] \
&& RDEPEND="!dev-embedded/avr-libc" \
|| RDEPEND=""

DOCS="AUTHORS ChangeLog* NEWS README"

pkg_setup() {
# check for avr-gcc, bug #134738
ebegin "Checking for avr-gcc"
if type -p avr-gcc > /dev/null ; then
eend 0
else
eend 1

eerror
eerror "Failed to locate 'avr-gcc' in \$PATH. You can install an AVR toolchain using:"
eerror " $ crossdev -t avr"
eerror
die "AVR toolchain not found"
fi
}

src_prepare() {
default

# work around broken gcc versions PR45261
local mcu
for mcu in $(sed -r -n '/CHECK_AVR_DEVICE/{s:.*[(](.*)[)]:\1:;p}' configure.ac) ; do
if avr-gcc -E - -mmcu=${mcu} <<<"" |& grep -q 'unknown MCU' ; then
sed -i "/HAS_${mcu}=yes/s:yes:no:" configure
fi
done

strip-flags
strip-unsupported-flags
}

src_install() {
default

# man pages can not go into standard locations
# as they would then overwrite libc man pages
docinto man/man3
dodoc -r "${WORKDIR}"/man/man3/.

# Make sure diff cross-compilers don't collide #414075
mv "${ED}"/usr/share/doc/{${PF},${CTARGET}-${PF}} || die
}

0 comments on commit e61d77f

Please sign in to comment.