Skip to content

Commit

Permalink
games-puzzle/pingus: Added live ebuild
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Apr 3, 2019
1 parent 9049f55 commit e64f0ba
Show file tree
Hide file tree
Showing 2 changed files with 83 additions and 0 deletions.
33 changes: 33 additions & 0 deletions games-puzzle/pingus/files/pingus-9999-no_libexec.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
From ef01ebf5401419a0e98dfe32efa9a0bc8564e26f Mon Sep 17 00:00:00 2001
From: Lars Wendler <[email protected]>
Date: Wed, 3 Apr 2019 18:35:28 +0200
Subject: [PATCH] Don't install pingus executable into libexec

This doesn't really make any sense.
---
CMakeLists.txt | 9 ---------
1 file changed, 9 deletions(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index f3a92be64..fa835236d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -213,15 +213,6 @@ if(BUILD_TESTS)
endif(BUILD_TESTS)

install(TARGETS pingus
- RUNTIME DESTINATION ${CMAKE_INSTALL_LIBEXECDIR})
-
-configure_file(
- ${CMAKE_CURRENT_SOURCE_DIR}/pingus.sh.in
- ${CMAKE_BINARY_DIR}/pingus.sh)
-
-install(FILES
- ${CMAKE_BINARY_DIR}/pingus.sh
- RENAME pingus
PERMISSIONS OWNER_EXECUTE OWNER_READ OWNER_WRITE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
DESTINATION ${CMAKE_INSTALL_BINDIR})

--
2.21.0

50 changes: 50 additions & 0 deletions games-puzzle/pingus/pingus-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit cmake-utils toolchain-funcs flag-o-matic xdg-utils

DESCRIPTION="free Lemmings clone"
HOMEPAGE="http://pingus.gitlab.io/"
if [[ "${PV}" == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/pingus/pingus.git"
else
SRC_URI="https://github.com/Pingus/pingus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3"
SLOT="0"
IUSE=""

RDEPEND="
dev-libs/boost:=
dev-libs/jsoncpp
media-libs/libpng:0=
media-libs/libsdl2[joystick,opengl,video]
media-libs/sdl2-image[png]
media-libs/sdl2-mixer[mod]
virtual/opengl
"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig"

PATCHES=(
"${FILESDIR}"/${PN}-0.7.6-noopengl.patch
"${FILESDIR}"/${P}-no_libexec.patch
)

src_prepare() {
sed '/find_package(Boost/s@ signals@@' -i CMakeLists.txt || die
cmake-utils_src_prepare
strip-flags
}

pkg_postinst() {
xdg_desktop_database_update
}

pkg_postrm() {
xdg_desktop_database_update
}

0 comments on commit e64f0ba

Please sign in to comment.