Skip to content

Commit

Permalink
dev-ruby/rbst: Bump to 0.6.5
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Aug 10, 2020
1 parent 09f585a commit e6c791d
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/rbst/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST rbst-0.5.1.tar.gz 14039 BLAKE2B 7399e92f98c650842464ea9240775ad776ec8d574c578d8da764778bbe8050be429e2521df82b3b04a0bf9cd18bef4f114890d54ef8d6f34c797f0f2f2e35bc2 SHA512 a7fffc1ccf495c1858d6d9fadd38a4d6a2c27a2da8eda8dad038f4ab881f4521223a35f97d4018d25b32c2621132a623040ba930494b36e1385356ecb87fecdc
DIST rbst-0.6.5.tar.gz 15760 BLAKE2B 3bace4401c8c92eba286f242c1e074aa833094c21e4b00bfa2eee982ad8cbb94024dda2210eb1c72ab88293b1a63a62a5bdeafde2615b0430bd0a7cc21ced14c SHA512 2d4a28c70a4925e1ffe0cd2ff10c275f67cae4a918c1064bd73cb8e7e490be251acff09670d78fef1edeb1a7dab8995aa0b4737563a0797ff66c0fee3f89bba2
51 changes: 51 additions & 0 deletions dev-ruby/rbst/rbst-0.6.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
USE_RUBY="ruby25 ruby26 ruby27"

RUBY_FAKEGEM_NAME="RbST"
RUBY_FAKEGEM_GEMSPEC="RbST.gemspec"

inherit python-single-r1 ruby-fakegem

DESCRIPTION="A simple Ruby wrapper for processing rST via docutils"
HOMEPAGE="https://github.com/alphabetum/rbst"
SRC_URI="https://github.com/alphabetum/rbst/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="
dev-python/docutils
${PYTHON_DEPS}"
DEPEND="
test? ( ${RDEPEND} )"

ruby_add_bdepend "
test? (
>=dev-ruby/minitest-5.14.0:5
>=dev-ruby/mocha-1.1.0:1.0
)"

pkg_setup() {
python-single-r1_pkg_setup
ruby-ng_pkg_setup
}

all_ruby_prepare() {
# do not use bundler
sed -i -e '/bundler/,/end/d' \
Rakefile test/helper.rb || die
# do not use python2
sed -i -e '/python2/,/end/d' \
test/test_rbst.rb || die

# force our python version
sed -i -e "s:\(python_path=\"\)python:\1${EPYTHON}:" lib/rbst.rb || die
python_fix_shebang lib/rst2parts
}

0 comments on commit e6c791d

Please sign in to comment.