Skip to content

Commit

Permalink
app-crypt/keybase: Version bump keybase-1.0.39
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.13, Repoman-2.3.3
  • Loading branch information
nicolasbock committed Dec 27, 2017
1 parent fbd6ce1 commit e712457
Show file tree
Hide file tree
Showing 3 changed files with 101 additions and 0 deletions.
52 changes: 52 additions & 0 deletions app-crypt/kbfs/kbfs-1.0.36.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit git-r3

DESCRIPTION="Keybase Filesystem (KBFS)"
HOMEPAGE="https://keybase.io/docs/kbfs"
EGIT_REPO_URI="https://github.com/keybase/kbfs.git"

LICENSE="BSD"
SLOT="0"
KEYWORDS=""
IUSE="git"

DEPEND="
>=dev-lang/go-1.6:0
>=app-crypt/keybase-1.0.17
"
RDEPEND="
app-crypt/gnupg
sys-fs/fuse
"

S="${WORKDIR}/src/github.com/keybase/kbfs"

src_unpack() {
git-r3_src_unpack
mkdir -p "$(dirname "${S}")" || die
ln -s "${WORKDIR}/${P}" "${S}" || die
}

src_compile() {
GOPATH="${WORKDIR}" \
go build -v -x \
-tags production \
-o "${T}/kbfsfuse" \
github.com/keybase/kbfs/kbfsfuse
use git && \
GOPATH="${WORKDIR}" \
go build -v -x \
-tags production \
-o "${T}/git-remote-keybase" \
github.com/keybase/kbfs/kbfsgit/git-remote-keybase
}

src_install() {
dobin "${T}/kbfsfuse"
use git && \
dobin "${T}/git-remote-keybase"
}
1 change: 1 addition & 0 deletions app-crypt/keybase/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST keybase-1.0.21.tar.gz 21127410 BLAKE2B 9f48b637aefa847ae5737937ed6bc3d9b7d222cda3ce5a388784104655092c1ad5fe0468680a1e0a02f5a7ea4fac1fb8e19430c9e4c3d542057953219976cd02 SHA512 60801ece5dc0df9f0da58143baf00729e1a79183d2b8209c405749f422dd8cecf7f4059e0799c88ca6e3f1e5a7ad8bd6805dd2401b0945954c6b1465c04974b5
DIST keybase-1.0.33.tar.gz 29170354 BLAKE2B 78799ea49cde32e3c1be781e281b5ca188f7a5d846fcb7e41605d6e2526bc4e36f6ef991567631e9c72eeb6b194ebec740516e886f4af419b01e47622f030c42 SHA512 d02933e88613102e27a4aa5f2494ae2b55456cab8c5cadad9c412069b24c574a20609fc83b88bc8f9aa00bfd300822bc4c882392f65fec3e7a8056cebc6fb9d4
DIST keybase-1.0.36.tar.gz 30043919 BLAKE2B 0053088754b0a4a47314032e87a7c5165aff59ded585ae20fb12c3dbf0c7437f7f0370f236fec0db501cacb3a75e87ed494df8f688d360c58904e851eb119f60 SHA512 c6bd4805240bdafd27eac382a30fac6e5ac3e6eb313dda027533c3a8f366077c894b38c1b972ff5688104e1ca4231cbf4242eeb168de9782bbac732da5639ed0
DIST keybase-1.0.39.tar.gz 30226025 BLAKE2B 5d10e4afe3f0f1691221cbf69ff3e427fe318768e74f5891d32416e92ad5c1c45ad3ff0c83ea2d2405f4492a2d2af989ff587c60c9a5677ae580c9502e9a5726 SHA512 def416bad6fc3513a3341aecaf03bce356a890667e4c64f9edc1c469b3a1f167c3022f6c1aabaa48257983aaa9826b45117ada6cc26bf862c97092c904cd32f1
48 changes: 48 additions & 0 deletions app-crypt/keybase/keybase-1.0.39.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils versionator

MY_PV=$(replace_version_separator 3 '-')

DESCRIPTION="Client for keybase.io"
HOMEPAGE="https://keybase.io/"
SRC_URI="https://github.com/keybase/client/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="
>=dev-lang/go-1.6:0"
RDEPEND="
app-crypt/gnupg"

S="${WORKDIR}/src/github.com/keybase/client"

src_unpack() {
unpack "${P}.tar.gz"
mkdir -p "$(dirname "${S}")" || die
mv "client-${MY_PV}" "${S}" || die
}

src_compile() {
GOPATH="${WORKDIR}:${S}/go/vendor" \
go build -v -x \
-tags production \
-o "${T}/keybase" \
github.com/keybase/client/go/keybase || die
}

src_install() {
dobin "${T}/keybase"
dobin "${S}/packaging/linux/run_keybase"
}

pkg_postinst() {
elog "Run the service: keybase service"
elog "Run the client: keybase login"
}

0 comments on commit e712457

Please sign in to comment.