Skip to content

Commit

Permalink
dev-python/pyminuit: added python3_5
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
Andrey Grozin committed Mar 4, 2016
1 parent 96db43e commit e72e588
Showing 1 changed file with 38 additions and 0 deletions.
38 changes: 38 additions & 0 deletions dev-python/pyminuit/pyminuit-1.2.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} )

inherit distutils-r1 flag-o-matic

DESCRIPTION="Minuit numerical function minimization in Python"
HOMEPAGE="https://github.com/jpivarski/pyminuit"
SRC_URI="
https://pyminuit.googlecode.com/files/${P}.tgz
https://pyminuit.googlecode.com/files/Minuit-1_7_9-patch1.tar.gz
"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""

S="${WORKDIR}"/${PN}

src_configure() {
cd "${WORKDIR}"/Minuit-1_7_9 && econf --disable-static || die
}
src_compile() {
cd "${WORKDIR}"/Minuit-1_7_9 && emake
cd "${S}"
distutils-r1_src_compile
}

python_install_all() {
cd "${WORKDIR}"/Minuit-1_7_9 || die
default
distutils-r1_python_install_all
}

0 comments on commit e72e588

Please sign in to comment.