Skip to content

Commit

Permalink
dev-ros/ament_cmake_cpplint: bump to 0.12.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Mar 15, 2022
1 parent 6fe9952 commit e75c1f1
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ros/ament_cmake_cpplint/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ament_lint-0.11.2.tar.gz 265435 BLAKE2B 09545bd029dc692e5393983a3fc9210600c4a6456635238b7038ff87799f9cfde9c2d3c7ceb4c01b71594ba7bd159e8b6b3c2370bdfcdbf3d6189a895b96292a SHA512 1a379f4fb0ead306a668aef2b9e390728d6d3901b75f43fac6ccc28681a8010e42b094237f3f1ab95ca304ba917c8fb5d5519ec0581cadb346e6eb05466e39f0
DIST ament_lint-0.12.1.tar.gz 281555 BLAKE2B 1feabfc9e65b09970cb9d9706e9fbc3ca8b60d0592597a8a8666f3b272e71a09c28bf3f21926f0f3b96d93e61d3f8c99286b2b5658359116305bbaf449b40207 SHA512 34625c9ff0615c09dc5e918896af5f46480de735388e57c06c8d8f3267cd98c7e0314ddc99d8ba328dbfa949c51eb893121f6639689f3a803503c77164e56bcc
58 changes: 58 additions & 0 deletions dev-ros/ament_cmake_cpplint/ament_cmake_cpplint-0.12.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{8..10} )

inherit cmake python-any-r1

ROS_PN="ament_lint"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_lint"
S="${WORKDIR}/${P}/${PN}"
else
SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
KEYWORDS="~amd64"
fi

DESCRIPTION="CMake API for ament_cpplint to lint C / C++ code using cpplint"
HOMEPAGE="https://github.com/ament/ament_lint"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
dev-ros/ament_cmake_test
dev-ros/ament_cpplint
"
BDEPEND="
$(python_gen_any_dep '
dev-python/ament_package[${PYTHON_USEDEP}]
dev-python/catkin_pkg[${PYTHON_USEDEP}]')
dev-ros/ament_cmake_test
dev-ros/ament_cmake_core
test? (
dev-ros/ament_cmake_copyright
$(python_gen_any_dep 'dev-ros/ament_copyright[${PYTHON_USEDEP}]')
dev-ros/ament_cmake_lint_cmake
)
${PYTHON_DEPS}
"

python_check_deps() {
{ use !test || has_version -b "dev-ros/ament_copyright[${PYTHON_USEDEP}]"; } && \
has_version -b "dev-python/catkin_pkg[${PYTHON_USEDEP}]" && \
has_version -b "dev-python/ament_package[${PYTHON_USEDEP}]"
}

src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=$(usex test ON OFF)
)
cmake_src_configure
}

0 comments on commit e75c1f1

Please sign in to comment.